summaryrefslogtreecommitdiff
path: root/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3-r2.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
index b17b9944fb34..aea6beb9b9f0 100644
--- a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
+++ b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit vim-plugin python-r1
DESCRIPTION="vim plugin: tab-complete your Python code"
HOMEPAGE="https://rkulla.github.io/pydiction/"
SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+S="${WORKDIR}/${PN}-master"
LICENSE="vim"
KEYWORDS="amd64 ppc ppc64 x86"
@@ -18,8 +19,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="app-arch/unzip"
RDEPEND="${PYTHON_DEPS}"
-S="${WORKDIR}/${PN}-master"
-
src_install() {
# Rename pydiction script.
mv "${PN}.py" "${PN}" || die