summaryrefslogtreecommitdiff
path: root/app-vim/iris/iris-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/iris/iris-1.0.0.ebuild')
-rw-r--r--app-vim/iris/iris-1.0.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-vim/iris/iris-1.0.0.ebuild b/app-vim/iris/iris-1.0.0.ebuild
deleted file mode 100644
index 984316d0a73f..000000000000
--- a/app-vim/iris/iris-1.0.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit vim-plugin python-r1
-
-MY_PN="iris.vim"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="vim plugin: mail client for vim"
-HOMEPAGE="https://github.com/soywod/iris.vim"
-SRC_URI="https://github.com/soywod/iris.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/imapclient[${PYTHON_USEDEP}]
-"
-
-DOCS=( README.md CHANGELOG.md )
-
-src_install() {
- mv api.py iris-api || die
- mv idle.py iris-idle || die
- sed -e 's#api\.py#iris-api#g;' -i autoload/iris/api.vim || die
- sed -e 's#idle\.py#iris-idle#g;' -i autoload/iris/idle.vim || die
- python_foreach_impl python_doscript iris-api
- python_foreach_impl python_doscript iris-idle
-
- vim-plugin_src_install
-}