summaryrefslogtreecommitdiff
path: root/app-vim/gundo
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/gundo')
-rw-r--r--app-vim/gundo/Manifest1
-rw-r--r--app-vim/gundo/gundo-2.6.2-r4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/gundo/Manifest b/app-vim/gundo/Manifest
index 04b8924a4403..f1a4b06cc28e 100644
--- a/app-vim/gundo/Manifest
+++ b/app-vim/gundo/Manifest
@@ -1,4 +1,5 @@
AUX gundo-2.6.2-python3.patch 395 BLAKE2B b39d17b6046f59d9a89fc89f4f6b941fb78777a98525993a046241f780087cf3450833cd966a42354a3d1f26a0171c5ed0d57aa11606ab42c9f04d44aaeafbfc SHA512 0fc80a6ade3a2b53843444a4ec9404d4d1ae54d5add0c5807a49c7a6818282f73c5635df69167a7f5b02da8b198bf83466f7b4da17f5d16f225a72081bd61df5
DIST gundo-2.6.2.tar.bz2 144107 BLAKE2B 7915a60a77e07e49cc1a214c6e250028e61ff33e6f085960836a3e49c1562f4ff713ff4c57125f677d352ae3477bb514fd94d636ee5ba9afac5d23c4ecd70029 SHA512 e03450a1bfb0a7f5013c1493f1b25b963c2bbb37fc8fa24c1b85237bd12847c3edd7b9465caae7bdadf8923dbdcdb24930b160d7824f835417bf30725fa910b4
EBUILD gundo-2.6.2-r3.ebuild 738 BLAKE2B 85f5cf5d1eb3eca59d8877d942124cadc42e946aa3558e4bf1fabf281e08816d7597208ad2a6641d0d507e3df5678c70c9dc93af16c7aa3f34344f25d486d10f SHA512 b418a8563343d63660900fe36f1e717756c13b0a221aa488843772d525831e6f4cecbb8e77056a5c9e0edc6177e3df515c424f8f90ba7446596a6097ed067fbe
+EBUILD gundo-2.6.2-r4.ebuild 741 BLAKE2B 270a345280848e9618a9b9f2a2bcf0f5e9d698652aa38f5279c8f388d1289b6cdb85487baa38452f3e8c29b9d7de118e59ae2a0173ea2db65f5740f2505cde9b SHA512 b8ef61dc9ccd27f06d694ade5db2cf04ed77eec0b1da0388e08833323b1675eeaf4f70df6a2cd4f745f0f6767c64f024d8b03b5d05237e55dd6a5d556b1e2930
MISC metadata.xml 363 BLAKE2B c840f208c7562daff03045c0d10801fb085b5df9e00ebdd230c7e33449e1d65759ae246bfcfb7c43d340799553998497f3c196410bc994aa59c66f977fd86189 SHA512 1885fd25b761f8a83516315354b9adf1477fd492667d9d091a4c9eb30ee31dd15c169811a6a66728a73b2ae132b92c6e19ca0d7e630c163916379465cf86ee48
diff --git a/app-vim/gundo/gundo-2.6.2-r4.ebuild b/app-vim/gundo/gundo-2.6.2-r4.ebuild
new file mode 100644
index 000000000000..32c0758b25dd
--- /dev/null
+++ b/app-vim/gundo/gundo-2.6.2-r4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://github.com/sjl/gundo.vim"
+SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+src_prepare() {
+ rm -r site tests || die
+ default
+}