summaryrefslogtreecommitdiff
path: root/app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild')
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild
new file mode 100644
index 000000000000..c1d5b6079805
--- /dev/null
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.3-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: enhanced comment creation"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=23"
+
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+VIM_PLUGIN_HELPFILES="EnhancedCommentify"
+
+# See bug #74897.
+RDEPEND="
+ ${DEPEND}
+ !app-vim/ctx"
+
+PATCHES=(
+ # See bug #79185.
+ "${FILESDIR}"/${PN}-2.1-gentooisms.patch
+ "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
+)