summaryrefslogtreecommitdiff
path: root/app-vim/easytags
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/easytags')
-rw-r--r--app-vim/easytags/Manifest1
-rw-r--r--app-vim/easytags/easytags-3.11-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-vim/easytags/Manifest b/app-vim/easytags/Manifest
index 049be10074f7..9f6c9c6edd1e 100644
--- a/app-vim/easytags/Manifest
+++ b/app-vim/easytags/Manifest
@@ -1,4 +1,5 @@
AUX easytags-3.11-fix-ctags-detection.patch 2964 BLAKE2B eafaddd9877d8732eeace0197ab29cedba38a89a1f7c4e1fb2192cb075bc7a4541e6a5e5448a8944a7f6a0b47fb1cd481035529d6b11d5508df35089f2e85865 SHA512 f3ef6cfce5cbbebc4d33fc5f6fe0b7df037c9ec80da6f4a2b29bccb15e00b385719e654238f6becea1372900ac5f9e5e6d6af481537dde12c03cda24ee49e674
DIST easytags-3.11.tar.gz 40572 BLAKE2B a6b228743f493bd467aff6685b6799de7e4862d384e14c81a084d7a211cf165d62cf902415a3c98a69858eded64c606bd4565f6e0c43fab7c078ba81d0ec5217 SHA512 9c1985a02b2718315d825ed29c06cbf78050e693893a9a7530a774031cbe9e6a27ee1dc91878950a1fbcaf7ea685faeb799d1e5b218b9ce25718783409f66130
+EBUILD easytags-3.11-r1.ebuild 1224 BLAKE2B d1784173bec8c978278e59586254b2bf6c9eaa9ac9ca744ff448eef65ae23f16d95476abd31d542ffdb2edbef70856142cc156bbb883bc57bfa93db6689fb370 SHA512 f1161fdfce9aa8ca733b25bb3ddcc187957e989b3b256fecdc4d314daa57e3b0979294d3ed2ad047748bbea48f573017531ba68df8270573e47cd4c2514760eb
EBUILD easytags-3.11.ebuild 996 BLAKE2B c3211f023786914dc5d9c9f76cff7295cc8c3ead593438d74cb31565aee0f5c0a7057a6d2b3581d63a1bbcc2d2e5a70add77b2e84e3e78d7b9cab5478b3942f9 SHA512 c351e922c7d4656a1d92e2aaed798b125b40bee89a7e4d758ba0ea197a204b4905d5d8f017dcf5d781ee865350c68fddc2814a856ef3f16abf404486595274a8
MISC metadata.xml 342 BLAKE2B 5e7e191544a04bc4ae28e482deef1c44c8ee11f6afe01d9ed6b138364f771411e341b5827e92bdfeae1edffdc166979c72a53034886530b0cdb55e34d9c2ce6e SHA512 0f4fbbedc023ccccc74ef8e020c3a90a0ccb0184164a52dd733699c5d4bf729d09478ea87fda093197679f7b44b3c1b64d3c64845d91d3fb92f9e3a1eab8fc78
diff --git a/app-vim/easytags/easytags-3.11-r1.ebuild b/app-vim/easytags/easytags-3.11-r1.ebuild
new file mode 100644
index 000000000000..cbd424d4f07a
--- /dev/null
+++ b/app-vim/easytags/easytags-3.11-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-vim/vim-misc
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S="${WORKDIR}/vim-${P}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
+
+src_prepare() {
+ default
+ rm addon-info.json INSTALL.md README.md || die
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+
+ # fix scripts
+ local f
+ for f in $(find "${ED}" -type f -name \*.py); do
+ ebegin "Fixing $(basename ${f})"
+ if [[ $f =~ highlight.py ]]; then
+ sed -e '1 i\#!/usr/bin/env python3' -i "${f}" || die "can't sed patch ${f}"
+ fi
+ 2to3 -w -n --no-diffs "${f}" >& /dev/null || die "can't convert ${f} to Python 3"
+ python_fix_shebang -q -f "${f}"
+ eend $?
+ done
+}