summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48600 -> 48591 bytes
-rw-r--r--app-text/docbook-xsl-stylesheets/Manifest1
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild97
-rw-r--r--app-text/groonga/Manifest2
-rw-r--r--app-text/groonga/groonga-13.0.1.ebuild107
5 files changed, 207 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index a4d67aacb434..0f05ae3b163e 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/docbook-xsl-stylesheets/Manifest b/app-text/docbook-xsl-stylesheets/Manifest
index 0fa0283d9a42..455b6a66bef2 100644
--- a/app-text/docbook-xsl-stylesheets/Manifest
+++ b/app-text/docbook-xsl-stylesheets/Manifest
@@ -1,4 +1,5 @@
AUX nonrecursive-string-subst.patch 1205 BLAKE2B 0c7bb8e3ba646a137bc0b50722448c65437881672a4bbb3f3dc7a181e5074f667fca0fbcb4475b83f04ac63bdddbf3dae800b7a7094b5d9aea270faeb81d9e50 SHA512 6a26838078a3ce28273dddfa1af6a378cffc28b6d1ba48a4cfc839addd7bf58ce217d6584b735f9c75381954744ab2386c75fa3c593858b6e27882be55c00d04
DIST docbook-xsl-1.79.1.tar.bz2 21967928 BLAKE2B 42b7e989616d16fa100c2dad713830ecedf6c7e26f56f99a9bf9330385c753f282cea1033e689196352bd41f9dca59a06ff09fc4638051cb478a630df9bfeb0b SHA512 83325cbaf1545da6b9b8b77f5f0e6fdece26e3c455164b300a1aa3d19e3bd29ae71fd563553a714a5394968d1a65684c6c7987c77524469358d18b8c227025c7
EBUILD docbook-xsl-stylesheets-1.79.1-r3.ebuild 2251 BLAKE2B 18286bcab2e0eac49b74b49ac241f0d9e0b0cf799c50f259455991a94a9cc49642c507e8e3365b57d9a3cd88654523007978444854c0e7239d3e81a71b3443a0 SHA512 258872fb8224ca0699025a8a9a8990b981e4595f5b2e538078fe266c0bb06ae844daa132d7d4171abc49721e07df1cba4eeab894844cad6f5e3ed18e334ac81c
+EBUILD docbook-xsl-stylesheets-1.79.1-r4.ebuild 2281 BLAKE2B af5b453297c44bb2c89b2ec46b019bdd3861b3ae0bb3ac5c6f025f6d2690c66c84766278bfc5b0f235e705434c5ef5c11194c89bcdbe75c1966c2e84efe3416a SHA512 60804c15a3959ab5997a01703036e269190e80053c61cff087aa29b1d8fbfa68f79e8cf60435a6d21f69214c8aeb44917573033919e8eb710f95463576f26d7a
MISC metadata.xml 414 BLAKE2B f10f5576731ded90514b956bb032bf6472634a509e709e998b0120ced275cea6d7027b18623b8f7d8198b6137a9566eab1b0462626a20693655c791b9763952e SHA512 f844b8d60c1c3413b8eb647bdffba6fb08e09e7f62df9e122ad6d69f9f67ec67711a66ec840f1ef92edefef83bd5e77103a10b0feeeb4a08f98680274c3dd93a
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild
new file mode 100644
index 000000000000..e47ba4f5bdda
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1-r4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+inherit ruby-single
+
+DOCBOOKDIR="/usr/share/sgml/${PN/-//}"
+MY_PN="${PN%-stylesheets}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="https://github.com/docbook/wiki/wiki"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ruby"
+# Makefile is broken since 1.76.0
+RESTRICT="test"
+
+RDEPEND="
+ >=app-text/build-docbook-catalog-1.1
+ ruby? ( ${RUBY_DEPS} dev-ruby/rexml )
+"
+
+PATCHES=(
+ "${FILESDIR}"/nonrecursive-string-subst.patch
+)
+
+src_prepare() {
+ default
+
+ # Delete the unnecessary Java-related stuff and other tools as they
+ # bloat the stage3 tarballs massively. See bug #575818.
+ rm -rv extensions/ tools/ || die
+ find \( -name build.xml -o -name build.properties \) \
+ -printf "removed %p\n" -delete || die
+
+ if ! use ruby; then
+ rm -rv epub/ || die
+ fi
+}
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+
+ insinto ${DOCBOOKDIR}
+ doins VERSION VERSION.xsl
+
+ local i
+ for i in */; do
+ i=${i%/}
+
+ for doc in ChangeLog README; do
+ if [[ -e ${i}/${doc} ]]; then
+ newdoc ${i}/${doc} ${doc}.${i}
+ rm ${i}/${doc} || die
+ fi
+ done
+
+ doins -r ${i}
+ done
+
+ if use ruby; then
+ local cmd="dbtoepub${MY_PN#docbook-xsl}"
+
+ # we can't use a symlink or it'll look for the library in the wrong path
+ newbin - ${cmd} <<-EOF
+ #!/usr/bin/env ruby
+
+ load "${EPREFIX}${DOCBOOKDIR}/epub/bin/dbtoepub"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ # See bug #816303 for rationale behind die
+ build-docbook-catalog || die "Failed to regenerate docbook catalog. Is /run mounted?"
+}
+
+pkg_postrm() {
+ # See bug #816303 for rationale behind die
+ build-docbook-catalog || die "Failed to regenerate docbook catalog. Is /run mounted?"
+}
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index 6b588e80ca6b..1bccd2321a45 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,5 +1,7 @@
AUX groonga.confd 259 BLAKE2B 440b084d0e41da1b81e27ffa1e42963ce22d83027841039d488d516dce8beffce0e2ca03f5ca78a6aae02fa7bf238f0cf900e770ebfba04cfac581a13bd2381f SHA512 489feed6a4c22eb2ac02be070dd84ed3eb677b4f250b7eacd5619c1749b322b302bdff36fc3586e83125ac7ef02569054c4f267ddd7b26e5aa378af428cbc8ea
AUX groonga.initd 715 BLAKE2B 0cf870704257490477a7a254a670ef5ce48141b8c9c4119446bcfab92972319857c77ebe41044c7d338b10bb720744788ce0313f8b2ee50277571513d0cfdb83 SHA512 7b4f789c9201f40fee0d99b94554bc33aebf024da02794143317215713cea3f2a9fda2e87d2a8bb864a7d0c8a2c44e824c65deecd4c95360423f7d3a4f04f8c2
+DIST groonga-13.0.1.tar.gz 24694524 BLAKE2B 326ca810bdf4634b778eb6efc7a6c56626b0c5b563d9b896da23a103399e51ca57e8d1dd87aa05dbbe527f67cb6875924ca073f007698f5077437e2b191b995a SHA512 54eda0c70f932f249dbf58f01367d9a05a9d8e6e9a1df92e0a9070f452596cfc38da59b02c5128a585f9e19d460ce8100dd2677aaba7049e129a963491b22362
DIST groonga-8.0.2.tar.gz 15095427 BLAKE2B fa83034a434edaa35dede08cb042e48f15e1e2edd78a121f9341f53f53a5eef863d02e2ea6384428c720c4ff9acf1083504046c8c11a1ea8d7bfc4b541db66b5 SHA512 bc5590604054c4adfbc80b39c7cf367e8a989c47d80c37c48feffb9a427b4b4e360289f3d732f6affa7d26a1c8559f23bda1c70b6736a06601398fce9a53acf1
+EBUILD groonga-13.0.1.ebuild 2468 BLAKE2B 90851ef9b24af7858b4070bd189583ed28504dd913ea36e712d576bf2b271cab3481892937bd7341981b9c4d8200e4a79c93eddeaab8a451aef853bcbca0e8ab SHA512 20e4255bd0a9bf6d601fd3100fab16bec206cc21c49534470970b01933572824d26571938d8bd7403872a056a22dc3655a2179ba74ced7741942b4ddb478f06a
EBUILD groonga-8.0.2-r2.ebuild 2586 BLAKE2B 23477e51ccdaede52c9aa4635833b81cd855d25a8737f4ac9c8e206d3590ec2eeb7d3d36c248f270a4205d7ee30a1079aaf6ec99375525e9c1e2668ec6a5669d SHA512 edfc467ffb7c4b557f169b6cabca9e122c55ce822fcfd7d9609ac4b079b858f00f0a8a4212aca2627dd6cb11b65da2f17048606e8caee5f3480c734f38c2335e
MISC metadata.xml 1227 BLAKE2B 1dde649077d52213dba0445f8e1993768efc4a2cf6d9ef6b733ce38167dc2e65f0b43c540c3a22586737ebe4522e7f003d857057fd3edc3bff60da2418778e15 SHA512 86a65f7d5613baff642107e6ffc1ad484f9f4361cc07985d1945d256560e8994ba7d1f21b5555dce80d6a00dcba0ce06d4d174db93a5b50f35d959428e99bfdc
diff --git a/app-text/groonga/groonga-13.0.1.ebuild b/app-text/groonga/groonga-13.0.1.ebuild
new file mode 100644
index 000000000000..bef5cf610056
--- /dev/null
+++ b/app-text/groonga/groonga-13.0.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="https://groonga.org/"
+SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark debug doc +exact-alloc-count examples futex jemalloc libedit libevent lzo +mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib zstd"
+REQUIRED_USE="
+ sphinx? ( doc )
+"
+
+DEPEND="
+ >=dev-libs/onigmo-6.1.1:0=
+ dev-libs/rapidjson
+ dev-libs/xxhash
+ benchmark? ( >=dev-libs/glib-2.8 )
+ jemalloc? ( dev-libs/jemalloc:0= )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent:0= )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack:= )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq:0= )
+ zlib? ( sys-libs/zlib:0= )
+ zstd? ( app-arch/zstd:0= )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/groonga
+ acct-user/groonga
+"
+BDEPEND="
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )
+"
+
+src_prepare() {
+ default
+
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # Apache arrow, kytea and libstemmer are not available in Gentoo repo
+ # ruby is only used for an http test
+ local econfopts=(
+ --disable-groonga-httpd
+ --without-pcre
+ --without-kytea
+ --without-libstemmer
+ --disable-arrow
+ --with-log-path="${EPREFIX}"/var/log/${PN}.log
+ --without-luajit
+ --without-ruby
+ --with-shared-onigmo
+ --with-onigmo=system
+ --with-xxhash
+ $(use_enable benchmark)
+ $(use_enable debug memory-debug)
+ $(use_enable doc document)
+ $(use_enable exact-alloc-count)
+ $(use_enable futex)
+ $(use_with jemalloc)
+ $(use_enable libedit)
+ $(use_with libevent)
+ $(use_with lzo)
+ $(use_with mecab)
+ $(use_enable msgpack message-pack)
+ $(use_with msgpack message-pack "${ESYSROOT}/usr")
+ $(use_enable nfkc)
+ $(use_with sphinx sphinx-build)
+ $(use_enable static-libs static)
+ $(use_enable uyield)
+ $(use_enable zeromq)
+ $(use_with zlib)
+ $(use_with zstd)
+ )
+
+ econf "${econfopts[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ if ! use examples ; then
+ rm -r "${ED}/usr/share/${PN}" || die
+ fi
+}