summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin48568 -> 48574 bytes
-rw-r--r--app-text/gspell/Manifest2
-rw-r--r--app-text/gspell/gspell-1.12.0.ebuild61
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index 45477b99119b..7fe7f89ccd5f 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index 834e65cba641..8a281d2f03ff 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,3 +1,5 @@
DIST gspell-1.11.1.tar.xz 432216 BLAKE2B aa6e6873fcb9cc7d3e7e05fe0abdd3b2e271c0483b7dc4d1c28179b87cea66b0fef86aa6ca94b7a571447ab70ac4ec55ac04b4b1f78415bea2db6c4f8fbc69ce SHA512 df13ef76340b3f644b517f05941c4a11f90212511229a4644cda0d605af428222bf7dd15dbdf51da80e07b7689249728f5739020349226b78d1990707f9706d9
+DIST gspell-1.12.0.tar.xz 433068 BLAKE2B 5726f40b07ee1d23a5a2e22ed012b52d6090a645b3141ecaf6a92cc850442be605ff2481a28ec87ee0d5b727b792fe2812a3e32ffd05978ed984d92b593910ec SHA512 7a9fea40c6b8298c48ee48cb6f67d66b0a950fd4d7902ffce0d2f620270614ea01b7ada0adba6778090b16f4561625aea6f39de76b743b2cd06a61a24520c549
EBUILD gspell-1.11.1.ebuild 1519 BLAKE2B b12f98d398de58a2637682c055a02691d61fa4f8ce7d6716a1bf8bd711b7f3447d61d2e6b9e5b9d1c88713bc2c663572328aa7039a1316e64f17c51e01adbe6f SHA512 30a043c539861fc4fb9f6f36d46b553f5d3ee77a89dbea2538eea82605c28bb293972f685450527676924ff6d165ecad72c49c4237565951a4622a7ffd40cabf
+EBUILD gspell-1.12.0.ebuild 1524 BLAKE2B e661270fff866f6f14d00ac6be9fab9e2b3c5db69c261d2d5ddb944e0e1cc23e65a9ecb99133b2407073a65b39dd3cb96471225f4257905a858dddf71032e931 SHA512 b05191ad4a46ced2f3814d13894d26b6ce087e3efc33e9c37f95703efd0f5cb8d8bf13c972c76541b90dcbee81fc414fa29a4182fcbf8c724508ce7f59163dc7
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/app-text/gspell/gspell-1.12.0.ebuild b/app-text/gspell/gspell-1.12.0.ebuild
new file mode 100644
index 000000000000..41d559da553d
--- /dev/null
+++ b/app-text/gspell/gspell-1.12.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.1.3:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ app-text/enchant:2[hunspell]
+ || (
+ app-dicts/myspell-en[l10n_en(+)]
+ app-dicts/myspell-en[l10n_en-US(+)]
+ )
+ )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx dbus-run-session emake check
+}