summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/Manifest.gzbin49796 -> 49783 bytes
-rw-r--r--app-text/cb2bib/Manifest4
-rw-r--r--app-text/cb2bib/cb2bib-2.0.2.ebuild57
-rw-r--r--app-text/cb2bib/files/cb2bib-2.0.2-qmake.patch49
-rw-r--r--app-text/cb2bib/files/cb2bib-2.0.2-unbundle-qtsingleapplication.patch27
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.11.1-r1.ebuild40
7 files changed, 178 insertions, 0 deletions
diff --git a/app-text/Manifest.gz b/app-text/Manifest.gz
index 0fd61706b7a4..3b451bcf16fe 100644
--- a/app-text/Manifest.gz
+++ b/app-text/Manifest.gz
Binary files differ
diff --git a/app-text/cb2bib/Manifest b/app-text/cb2bib/Manifest
index bcec7824537d..4dd674850668 100644
--- a/app-text/cb2bib/Manifest
+++ b/app-text/cb2bib/Manifest
@@ -1,3 +1,7 @@
+AUX cb2bib-2.0.2-qmake.patch 1781 BLAKE2B c7d4163b2c0cf5a41eca40dd9ddba9a7f4da65d977b4f96986745f80e200419a514b2fee8f8603f39994722057d5e6ac02e0676fe3ba05da0eb64ec92d2a2977 SHA512 ff847964386a565bc2fb4d7ccf3c065e73f73ef68c69c5e18dc705031f8f4ede9050557ec389e58b31ed0a856d15e33059e9a829bc2d2611f97f6cd7ce74fcb9
+AUX cb2bib-2.0.2-unbundle-qtsingleapplication.patch 725 BLAKE2B a0ddd10689f6d60862fc6316f5ea34e1ef71422a12cf8be91dc3cfd80a4ddfbb5d6bceec4168ebaf4861936817c04aaad8f96569531a29a25b8531312ed3f440 SHA512 486205186d526dfd97f8dc6623984a8d6f7fa16b0b751eb420af9486ce0a889dfc947ea60b8792d9114115229ecb30b08d22d6e08be43941c4df16e17bff3568
DIST cb2bib-2.0.0.tar.gz 1337422 BLAKE2B 6b1137c162f69f6d875aa3ae73b5995a067b332b3a7c0a5e69b787f352810768559c227c793204ca40ec594667624d329b5202c28056bca2e13110afebe57f63 SHA512 de1f3a36b98e016c5fa7317ba3fa8c5b767bd4b37bad1318298a57999bead4cc70d18ac49bb87fde57c4379f3347988846a7aa9b88e23a381d6c193bb1354cc2
+DIST cb2bib-2.0.2.tar.gz 1366292 BLAKE2B 7d2657103cf6aeedf343111794b613c037fae3ca3cf57c52d9eb25470142a87ec2f39927673ed5662809f1caf861e29ef011d1563ee18b0a05aac1909d577e9d SHA512 cb367fc043b837e131559832ad36b0fa3a5c619d1694d2a08e6086d4c48ae1d06171b46b4992154ce185322e29389a261092ea1b17ea90c02e58df9cf171d9c1
EBUILD cb2bib-2.0.0-r1.ebuild 1699 BLAKE2B c0db9378e85c93e65c7f40eff4fd91156bdd24e08432e062a36395acbb1d9590e1032e54296c55d5a7f1819e7d94446340e0fef40cd4a7766c007ede54fd4976 SHA512 4626f3b2db35b4fdda87b818ccf3e466ca80d3a8c5aa2418897e13970e0501ce33d9bd8f89d8b755379b04177d72f5e25210dd809a2d97ca948f8cd87c7c5d9e
+EBUILD cb2bib-2.0.2.ebuild 1462 BLAKE2B 21246438fd5448450b1abb01209d21dee54144980f5450ab25ffbfeb5d47cb0309a850d6d218135bf4de8f8cdb1c4691ded6198120a4481cb1fc8e93b998b038 SHA512 14580c7fe490a179a76feb8c94edae51c330dc0851700107c7279cd09a54dc44f89a79300566926579067a1051d0864ba3849b821161e3983f69ee232a090586
MISC metadata.xml 245 BLAKE2B 695adbeae3aac756b61dadb8ece9e0e33e402001317629cb64ef83702b858a91431c2cb20235589629f22b38a80e0732f572438211bfae63b955041526d55e31 SHA512 514e028bdd6e8aabecf1569c98677e1162de664b924324470ca5979eb85cd20bd1ba1f1c010d7de60876af7856bc1d6377dfaa99c5121eeddd17e6e8cc86f6be
diff --git a/app-text/cb2bib/cb2bib-2.0.2.ebuild b/app-text/cb2bib/cb2bib-2.0.2.ebuild
new file mode 100644
index 000000000000..ae177e4bfebd
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-2.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature qmake-utils xdg
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="https://www.molspaces.com/cb2bib/"
+SRC_URI="https://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# build system supports lzo, lzsse, qt_zlib, avx2, but too painful to expose
+
+DEPEND="
+ app-arch/lz4:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsingleapplication
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS CHANGELOG COPYRIGHT )
+
+PATCHES=(
+ "${FILESDIR}/${P}-qmake.patch" # bug 953061
+ "${FILESDIR}/${P}-unbundle-qtsingleapplication.patch" # bug 489152
+)
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ # bug #709940, still needed as of 2.0.2
+ emake -j1
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "displaying mathematical notation" "media-fonts/jsmath"
+ optfeature "proper UTF-8 metadata writing in PDF text strings" "media-libs/exiftool"
+ optfeature "BibTeX file correctness checks and nice printing via bib2pdf shell script" "virtual/latex-base"
+ optfeature_header "Install additional packages for optional import data formats:"
+ optfeature "PDF files" "app-text/poppler[utils]"
+ optfeature "DVI files" "app-text/dvipdfm"
+ optfeature "ISI files, endnote format" "app-text/bibutils"
+}
diff --git a/app-text/cb2bib/files/cb2bib-2.0.2-qmake.patch b/app-text/cb2bib/files/cb2bib-2.0.2-qmake.patch
new file mode 100644
index 000000000000..f589cd928a06
--- /dev/null
+++ b/app-text/cb2bib/files/cb2bib-2.0.2-qmake.patch
@@ -0,0 +1,49 @@
+From 5703387d1a720eb8b02e9e1c35e7d06158df9167 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 3 Apr 2025 21:38:10 +0200
+Subject: [PATCH] Disable qtwebkit, qtwebengine, installation of
+ AUTHORS/COPYRIGHT/LICENSE/CHANGELOG files
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/src.pro | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/src.pro b/src/src.pro
+index c5f1523..b19104c 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -130,10 +130,10 @@ LIBS += -lc2b
+ QMAKE_LIBDIR += .
+ INCLUDEPATH += c2b .
+
+-qtHaveModule(webkitwidgets){
++false{
+ CONFIG += use_webkit
+ } else {
+-qtHaveModule(webenginewidgets){
++false{
+ CONFIG += use_webengine
+ }}
+ CONFIG(use_webkit) {
+@@ -203,7 +203,7 @@ desktop.files += ../c2bscripts/cb2bib.desktop ../c2bscripts/c2bciter.desktop ../
+ desktop.path = /usr/share/applications
+ icons.files += ../src/icons/cb2bib.png
+ icons.path = /usr/share/pixmaps
+-cb2bibdata.files += ../AUTHORS ../COPYRIGHT ../LICENSE ../CHANGELOG ../data ../c2btools ../testPDFImport
++cb2bibdata.files += ../data ../c2btools ../testPDFImport
+ cb2bibdata.path = /usr/share/cb2bib
+ cb2bibdoc.files += ../doc/cb2bib_user_manual.pdf
+ cb2bibdoc.path = /usr/share/cb2bib/doc
+@@ -217,7 +217,7 @@ INSTALLS += target script cb2bibdata
+ target.path = /Applications
+ script.files += ../c2bscripts/c2bimport ../c2bscripts/c2bciter
+ script.path = /Applications
+-cb2bibdata.files += ../AUTHORS ../COPYRIGHT ../LICENSE ../CHANGELOG ../data ../doc ../c2btools ../testPDFImport
++cb2bibdata.files += ../data ../doc ../c2btools ../testPDFImport
+ cb2bibdata.path = Contents/Resources
+ QMAKE_BUNDLE_DATA += script cb2bibdata
+ # Set this directory if third party tools, like pdftotext are packaged
+--
+2.49.0
+
diff --git a/app-text/cb2bib/files/cb2bib-2.0.2-unbundle-qtsingleapplication.patch b/app-text/cb2bib/files/cb2bib-2.0.2-unbundle-qtsingleapplication.patch
new file mode 100644
index 000000000000..3aa85f8c422a
--- /dev/null
+++ b/app-text/cb2bib/files/cb2bib-2.0.2-unbundle-qtsingleapplication.patch
@@ -0,0 +1,27 @@
+From 2716710a85806c8fa88e6555a4d833b149bc2718 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 3 Apr 2025 21:43:11 +0200
+Subject: [PATCH] Unbundle qtsingleapplication
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/src.pro | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/src.pro b/src/src.pro
+index b19104c..d65e904 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -120,8 +120,7 @@ SOURCES += bookmarkPlugin.cpp \
+ findDialog.cpp \
+ main.cpp
+
+-HEADERS += $$files(qtsingleapplication/src/*.h)
+-SOURCES += $$files(qtsingleapplication/src/*.cpp)
++CONFIG += qtsingleapplication
+
+ TEMPLATE = app
+ QT += widgets network
+--
+2.49.0
+
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 240e747c8fea..4c25eaf7f5a4 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1,5 +1,6 @@
DIST pdfarranger-1.11.0.tar.gz 450491 BLAKE2B a34323e2491412bd192ee49106008388170452fa2ff150c56a03573a18582e65457e213db2e0f33b909b6e442acd30f397a3167d560555f2d9b70a2b0daca985 SHA512 b5eb91ea0157453928e908fb13857929364d3cb0fa6872c1a2c2a60f654bebdeaf88da483071e52727dc1943f972fa78e919e4b46a63a131795018c125dfee48
DIST pdfarranger-1.11.1.tar.gz 455095 BLAKE2B cc4aebaf27cf2bf66c9ffa6f7519345461072aa36bcdf604f615b4d7366d96d972ff63fc6b3897e424a07c6bcbb78816f275b760335a22056bc9ced6f09618ff SHA512 910c0b03c61f195c5adc054acd249c6a735e276990fdf3f3a77c3538917e76dbf46a8665571730092d1fb23edfad1e97b95337b51fbfe92d1d553c0a78e98cfe
EBUILD pdfarranger-1.11.0.ebuild 1035 BLAKE2B 1b99f9738e95cd40d5ff8f534f5a4d1c1e800a117d9e3dbe441e3f28bd55cd0e99b5338842864f0e8b4d8a4da52df839d05cb9fb7874eb85809ab38fa86efafa SHA512 d766b2edd4cffef0b03cf7f53d0448275240e3e5955fcfba599f9de522bd02274390fa604d80443e20d1d7313650ff7d8917508ba66d18a542dbbaae2605aee1
+EBUILD pdfarranger-1.11.1-r1.ebuild 1036 BLAKE2B d883ec77b44bb20a71bd8061c0a43fb885cfb8e3883e01f83e23ecbbbb0ef12dad8f97bb3b4c049c5f79bd30478788df42f71f806b93cf59922bce6cdc0ec300 SHA512 ba2471a86d806d6ba5e9b2cc863bf54d9e0ebe3413e68dbc80d68711cd479bd6347e8cae2fe58bf62a1bbc52c2e6b4bfba89b50e3ab29f2c50aa3c3528bda5a1
EBUILD pdfarranger-1.11.1.ebuild 1036 BLAKE2B 6ee52bb80de1f65ebea50d9993007aae84c41c7836490032ab90e7c241b8b69d5b9f2003cf7e5d98be8f471cb061942e981bba514a51eeb34749fdebc3f2743a SHA512 454a934d8d81fdc0b627e41474eea558d5edab5164c35ed74508506111b7f2ef0b760032d286fbcfba4d6c8d844875048d439c57e3a96d4b00ebc54f49617a45
MISC metadata.xml 623 BLAKE2B 97df25f636b64ca18e0ba7160d85e683459b8c701c903187628924f5b7c2084c953284e2c727fbdcde0edf87a0a895d1b57d8570423f3ffaf88ad8a3ca3e5aee SHA512 3bc66e897609200efdc078f029998feba9cf4918cee1fba2f1edb6c79334a0f8bb1f716103eae2c7b2250533d1cd6845bdce27527798e76db0fa88fd6b0ba923
diff --git a/app-text/pdfarranger/pdfarranger-1.11.1-r1.ebuild b/app-text/pdfarranger/pdfarranger-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..57f0f202a848
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.11.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..13} )
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}