summaryrefslogtreecommitdiff
path: root/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild')
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
new file mode 100644
index 000000000000..2de3b88232f7
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-text/djvu-3.5.24-r1:=
+ >=app-text/zathura-0.3.1
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}