summaryrefslogtreecommitdiff
path: root/app-text/xml2doc
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/Manifest4
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild41
2 files changed, 19 insertions, 26 deletions
diff --git a/app-text/xml2doc/Manifest b/app-text/xml2doc/Manifest
index 21b91ae07d53..dad5e21718dc 100644
--- a/app-text/xml2doc/Manifest
+++ b/app-text/xml2doc/Manifest
@@ -1,4 +1,6 @@
+AUX xml2doc-20030510-gcc10-no-common.patch 195 BLAKE2B 3c90b98f57ae23f78b586dadf8a53b1a092597bef4e1bfee41fef5ce47cf6c639e03a59a8985434c931b0e7a803262d8f03874b2b4c676980efe62b913f214d6 SHA512 4fc3640be15c6c5192bb2a2a74ced1ebc22fd33bd2c49a39df295239e8b4b4047d6c840e23df091c060dcb6895a0dc1552127de0029d2d403214352e8f7f218f
+AUX xml2doc-20030510-makefile.patch 2661 BLAKE2B d9822ba57187553ae6da3f2b3f146bd3ae4316a99cb9608d88112a18462345c4614e167bb3757a723b6a12e2b521f1a2fb575ef19db480ed45fa60e133297c38 SHA512 c5aee7f9b98f1c64345459cb3ad6132082c04020a56f39fa950584689953c1058564332351a5b51e130e077fbe15c08ea88f35504888a153bfc878d8210b8b00
AUX xml2doc-pointer_fix.patch 627 BLAKE2B 3ca9313b44d88fce3f548874d40ed57b42b9faa66e30574677c911f7d5c9d0a8d5eea8c35781162302543df82c5b38b1327fcaabee0a50c396c95937c3a86e44 SHA512 ebdf69986821fdb1a22e3da4447729433d7f30d08e516b5b28c1f9e4fe6ec98d7a31e925028f940e8a0aaab5c05bd52a1a4d12564fd47a79953b1de606fd2430
DIST xml2doc-20030510.tgz 53307 BLAKE2B 3f7e44ede6ac0a2ec4762e66181de34ffe553035b54ee302345d1b38a5063106fc4ba65abec042b4ec693b173d70fc4b548ebc942b2a8f6636f84e7beeed2bd6 SHA512 9eb2970b7adef1669b9b0aede2b3d2b42ba234c8294f0f8e6e230d8fcc6cf878675b2f0bff87ee36a255ab29376be844d92d382be7aad0ab11972847cfe49dbd
-EBUILD xml2doc-20030510-r1.ebuild 1189 BLAKE2B 85aad44ccaee3ae47e8e7e6ffc2e0e352a8b6fe5e3d141bd01bd2be35e55ea84664e4fe86e451218658ad5323f42d41ecae02883292456b947a569ab6c6f2cf6 SHA512 b5faa7a55c0884b083bdfc47ce539a81d4df515b232bc4563ff8a4dd809c886dc9b18c472cca3ae406f872467d59606094df2c59aed5b28d2e3b454fd38b7cc3
+EBUILD xml2doc-20030510-r1.ebuild 1010 BLAKE2B c66afdbad87d601f358b7fe438c4f483833c4b84f38dfb12ffd904ca9d3594c3eaa9228b19af46432b0583c879cc8248f83ed74d6a9c161c6f0a0e0ebd7e2c18 SHA512 1b15699e2cdf8ed954631369a4f83683ff0d0c86a23a539494877704867c90708bfaebed4b0a0966c8c61a2aa92e4078727e9df3ffff28d990264f193050b649
MISC metadata.xml 244 BLAKE2B 6c0f152456a096c4bfbf861d8d7db04d0b8c605deb5f9a3277cd6b60df4a714c77bb12d5e4a491a193da11883447855986468ecf5c707600febbed973253181d SHA512 b4abe1dd13476a480e518e284cb832c2b41893049169975ee44edba8661af79b7cd8f8110e03b920fe90cd8e0e1d926bd5a692a24ecb841bd454659de3422ee9
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
index 481bd3d247ee..e4a387e503a4 100644
--- a/app-text/xml2doc/xml2doc-20030510-r1.ebuild
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -1,59 +1,50 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
-
HOMEPAGE="http://xml2doc.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2"
-IUSE=""
SLOT="0"
-
KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
-DEPEND=">=dev-libs/libxml2-2.5"
+DEPEND="dev-libs/libxml2:2"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- # Fix pointer-related bug detected by a QA notice.
- epatch "${FILESDIR}/${PN}-pointer_fix.patch"
+S="${WORKDIR}/${PN}"
+PATCHES=(
+ # Fix pointer-related bug detected by a QA notice
+ "${FILESDIR}"/${PN}-pointer_fix.patch
# Don't strip symbols from binary (bug #152266)
- sed -i -e '/^\s*strip/d' \
- -e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
- -e '/^\t$(CC) $(CFLAGS) /d' \
- src/Makefile.in
-}
+ "${FILESDIR}"/${P}-makefile.patch
+ # fix GCC 10 -fno-common change
+ "${FILESDIR}"/${P}-gcc10-no-common.patch
+)
src_configure() {
+ tc-export CC
econf --disable-pdf
}
src_compile() {
- emake CC="$(tc-getCC)"
+ default
- cd "${S}/doc"
+ cd doc || die
"${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
}
src_install() {
- # xml2doc's make install is unfortunately broken
-
- # binary
dobin src/xml2doc
- # documentation
- dodoc BUGS README TODO
+ einstalldocs
docinto examples
dodoc examples/*.{xml,png}
- # manpage
doman doc/xml2doc.1
}