summaryrefslogtreecommitdiff
path: root/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild')
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild b/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild
new file mode 100644
index 000000000000..38e7ce7168da
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/"${PN}-0.7.8-tests.patch" )
+
+python_compile_all() {
+ emake -C man
+}
+
+python_test() {
+ "${EPYTHON}" test/run || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman "man/${PN}.1"
+}