summaryrefslogtreecommitdiff
path: root/app-text/xchm
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xchm')
-rw-r--r--app-text/xchm/Manifest7
-rw-r--r--app-text/xchm/files/xchm-1.23-wx3.0-compat.patch32
-rw-r--r--app-text/xchm/files/xchm.desktop11
-rw-r--r--app-text/xchm/files/xchm.xml7
-rw-r--r--app-text/xchm/metadata.xml11
-rw-r--r--app-text/xchm/xchm-1.23-r1.ebuild50
-rw-r--r--app-text/xchm/xchm-1.23-r2.ebuild51
7 files changed, 169 insertions, 0 deletions
diff --git a/app-text/xchm/Manifest b/app-text/xchm/Manifest
new file mode 100644
index 000000000000..345cb03d164d
--- /dev/null
+++ b/app-text/xchm/Manifest
@@ -0,0 +1,7 @@
+AUX xchm-1.23-wx3.0-compat.patch 929 BLAKE2B 87f22da40033007e071ff3c1ca49724702731decff28cbe46ee6722da86ce03e5e569419cb077fdbc00132d19288c5794e09a2a43a6748da58a9fb899d85128d SHA512 7813bb885d9a62dd9da8484875cac5436b68cf1fbcc0212089c9cc10b104ffb05ea7af768a3a182c72f660c1be49a1f990700532416a7b7c028b282ecd83fca4
+AUX xchm.desktop 251 BLAKE2B 69b8a13fbf6129aedb89f558541728bdce055a585387d1cec49c08f86b6a5d972287b63fe2ba719b83bcab9270e07c1c0d50ccaeff36bc8cd291fa7602a67863 SHA512 c17e6e3957d4c0720e43dd64b169daf221e26652fd6487d2838a4c4aa86cd9640e651d55e6bc28dd4c4cc7b37624baf83df55061583f65eeecc592bd2c9a5e54
+AUX xchm.xml 257 BLAKE2B 0b32e654afe5af057c219830f61989e2266d55c726b90cc73795ab260034e162d16af2ecce463d74feb136b5b7bfd6e8544a56d883c349bf3158f750aba05212 SHA512 c2dc02da01dce9be31c92d95c28d8ada8c9532499d4f5d8875b41a42bd1f070f6f938e7f4cafdb8d42b13298d81eb03c3347e19c70b395f872888fac5a658533
+DIST xchm-1.23.tar.gz 474274 BLAKE2B de73c04e68b876edefb1d45d9e982bcce6fd3afa06f8704d05fa5cae710d9724ed20ca50be9022570832da9954ba2af141a66e5b3ab02554441c84bac1d6ffed SHA512 c0df4362ff6db8136b20f62a76e7e93185375f6ef9eeeb1001e27ead9806d486332573ba8c3ca1863a70ce6b1d3bcc6d3af48d42add719312774dccfd7d18c90
+EBUILD xchm-1.23-r1.ebuild 1089 BLAKE2B 58c42b1eb68d2f84a421e511504b476eaf20e4033c54c032c438ec91a01ea3dc5afdc401ee0b15d650c8df1fcedd07a0a146c172f1d5cffcd4d8074575c561be SHA512 1e2ea33bb90588ba970930ccd7ab8f4fc696e03e1088dec1f65da5be8f139627cac104d9b53a6131a2c0ad2efca0747e0d17d77a684762967a688fba98016ace
+EBUILD xchm-1.23-r2.ebuild 1066 BLAKE2B a195970c160cc7216b1b4eacf079e33f8ed4391ac630eadd49fe60953858804dfe3003af5f4b493d9863bb1ec9750d05be2c30ffdbd8eae5900ab00011b094b7 SHA512 25d23d01ea964f0a924544d90b422dfba200ffb528c4ef0c1f2ef866df857936bc324969711b6de2ec5c609709b26c8b4ca9c9da94be84d7cd85127ca8f35cfb
+MISC metadata.xml 350 BLAKE2B f6872e04718f72ae186772afc32f65a55ed55f078f53c6b3a8448bffcf006eb65ef1923e98d369af3e9c6fda5977bd148ae13a2d8e32ab2e2a6680a4ec5fe2c6 SHA512 956319a7ec2b136c5a1b38a51ab1fb61f81274dc2898eff1441393ddc4d0c204854093800210b9e44ef214427e4664f61d0ba1c3a8c43d8f21812b55371e3e66
diff --git a/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch b/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch
new file mode 100644
index 000000000000..a9545cf5b568
--- /dev/null
+++ b/app-text/xchm/files/xchm-1.23-wx3.0-compat.patch
@@ -0,0 +1,32 @@
+Description: Fix code to compile with wxwidgets 3.0
+ Drops support for wx < 2.7, which is just not relevant now. And in fact
+ configure.ac checks for at least 2.8.0.
+Author: Olly Betts <olly@survex.com>
+Last-Update: 2014-03-07
+
+--- xchm-1.23.orig/src/chmframe.cpp
++++ xchm-1.23/src/chmframe.cpp
+@@ -265,11 +265,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
+ enu.EnumerateFacenames();
+ _normalFonts = new wxArrayString;
+
+-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
+ *_normalFonts = enu.GetFacenames();
+-#else
+- *_normalFonts = *enu.GetFacenames();
+-#endif
+ _normalFonts->Sort();
+ }
+
+@@ -278,11 +274,7 @@ void CHMFrame::OnChangeFonts(wxCommandEv
+ enu.EnumerateFacenames(wxFONTENCODING_SYSTEM, TRUE);
+ _fixedFonts = new wxArrayString;
+
+-#if wxMAJOR_VERSION == 2 && wxMINOR_VERSION >= 7
+ *_fixedFonts = enu.GetFacenames();
+-#else
+- *_fixedFonts = *enu.GetFacenames();
+-#endif
+ _fixedFonts->Sort();
+ }
+
diff --git a/app-text/xchm/files/xchm.desktop b/app-text/xchm/files/xchm.desktop
new file mode 100644
index 000000000000..a8842132a170
--- /dev/null
+++ b/app-text/xchm/files/xchm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=xCHM
+Comment=Compiled HTML Help (CHM) file viewer
+Comment[fr]=Visionneuse de fichiers Compiled HTML Help (CHM)
+Icon=xchm
+TryExec=xchm
+Exec=xchm %f
+MimeType=application/x-chm;
+Categories=Office;Viewer;
diff --git a/app-text/xchm/files/xchm.xml b/app-text/xchm/files/xchm.xml
new file mode 100644
index 000000000000..08cb9ca3f4b8
--- /dev/null
+++ b/app-text/xchm/files/xchm.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-chm">
+ <comment>Compiled HTML Help Format</comment>
+ <glob pattern="*.chm"/>
+ </mime-type>
+</mime-info>
diff --git a/app-text/xchm/metadata.xml b/app-text/xchm/metadata.xml
new file mode 100644
index 000000000000..e0b21d3488e8
--- /dev/null
+++ b/app-text/xchm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>desktop-misc@gentoo.org</email>
+ <name>Gentoo Desktop Miscellaneous Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">xchm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xchm/xchm-1.23-r1.ebuild b/app-text/xchm/xchm-1.23-r1.ebuild
new file mode 100644
index 000000000000..26b4e3e15f86
--- /dev/null
+++ b/app-text/xchm/xchm-1.23-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+WX_GTK_VER="3.0"
+
+inherit eutils flag-o-matic wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="http://xchm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wx3.0-compat.patch
+
+ append-flags -Wno-unused-local-typedefs
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/app-text/xchm/xchm-1.23-r2.ebuild b/app-text/xchm/xchm-1.23-r2.ebuild
new file mode 100644
index 000000000000..f7ee063880c7
--- /dev/null
+++ b/app-text/xchm/xchm-1.23-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="http://xchm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}"/${P}-wx3.0-compat.patch )
+
+src_prepare() {
+ setup-wxwidgets
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}