summaryrefslogtreecommitdiff
path: root/app-text/wv2
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/wv2')
-rw-r--r--app-text/wv2/Manifest1
-rw-r--r--app-text/wv2/wv2-0.4.2-r4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/wv2/Manifest b/app-text/wv2/Manifest
index 23ba073a2a84..6ec26cdd890d 100644
--- a/app-text/wv2/Manifest
+++ b/app-text/wv2/Manifest
@@ -2,4 +2,5 @@ AUX wv2-0.4.2-glib.patch 312 BLAKE2B 7c68aff28688cf4ad7ee99c73d4509197e958bf05fc
AUX wv2-0.4.2-libgsf.patch 425 BLAKE2B 417d6b340c34dffee0301308ee5a04f4468a5627670638399535f7336cca7515927392e66dd723e8a13742e71ccb1bf850c7b91608b7f280b545a707d6425a2d SHA512 634b1a336506777f8976b81cd906f8a896e2b777a3f04c5791277ed5ca2856dacb71adab807efecdf29d07c02e4c95b5d6fe143b1660be77e37ed9d7bd177143
DIST wv2-0.4.2.tar.bz2 452759 BLAKE2B 6134739459617189f9d4e11a660dac25114b5d329b43d02fffe773d25bf62f2eb9f4ccb2712016e670c72f089a6d48f764e99b0ce5d44554d3e9d69ea9e14762 SHA512 7b4fb1dc6aa05da52ea169bf13f3bb544a7a896cf9127b6d67a08e991d798e81e2bf65724cf9396a9b89902f7856007006d8b123fcaaccce77e2a4668a9c9d5b
EBUILD wv2-0.4.2-r3.ebuild 822 BLAKE2B b657d2a88276bc57f275626bc793b43a7b50aa8155045fd5b8c7e31e8eddd6cff9d222ec6dfc8ace0a0723aaf677520adcd94fc97ae9dc6bea0bc142c662537a SHA512 e5702f615e3fbc69b07667aeda7768c65ab506388389de6d3c68fe57dc98566bfe47d57380bde7f6339a96a3231edc1aab95e80f7c8962dd3c1ab5794d8b2f07
+EBUILD wv2-0.4.2-r4.ebuild 907 BLAKE2B 340686855a7123585a403a66dcae0b8146c5354eda80e04f9e35589a951ccb7a02c1454bbbb64b04b8995e5aedd2265240d1c98e37f816ecbfe62e60f2294e31 SHA512 01aac9473ffa517283f853b12420467ae8901a05fc9067d8dbdd727957d03e4229e265d4ac7d514f830e93ca957d73ff19ea7a99fb2651b837690e6278745c5c
MISC metadata.xml 386 BLAKE2B 0396f27bba8e94b9a420d5e8a76433fc99d5552bb4e1c6065536184255418ed5329208c72d2810ae08425bb1cfcdcf711154886298de0ea0e249fca2aac7a921 SHA512 0c0494abe579cc546426df511abebd6f02d5907976fd7f21cbd2f2fd1a0fcfd9662540b115a1768f1957d48b228d41d582f888a14f08956c14d4c55dd792392f
diff --git a/app-text/wv2/wv2-0.4.2-r4.ebuild b/app-text/wv2/wv2-0.4.2-r4.ebuild
new file mode 100644
index 000000000000..991e3e04721b
--- /dev/null
+++ b/app-text/wv2/wv2-0.4.2-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
+HOMEPAGE="https://wvware.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/wvware/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="zlib"
+
+RDEPEND="dev-libs/glib
+ >=gnome-extra/libgsf-1.8:=
+ virtual/libiconv
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
+)
+
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
+
+src_configure() {
+ # Due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.la' -delete || die
+}