summaryrefslogtreecommitdiff
path: root/app-text/wgetpaste/wgetpaste-2.25-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/wgetpaste/wgetpaste-2.25-r3.ebuild')
-rw-r--r--app-text/wgetpaste/wgetpaste-2.25-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/wgetpaste/wgetpaste-2.25-r3.ebuild b/app-text/wgetpaste/wgetpaste-2.25-r3.ebuild
new file mode 100644
index 000000000000..b159d3d8f938
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.25-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-misc/wget"
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ epatch "${FILESDIR}"/wgetpaste-2.25-pinnwand.patch
+ epatch "${FILESDIR}"/wgetpaste-2.25-pinnwand-raw.patch
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /etc/wgetpaste.d
+ newins "${FILESDIR}"/wgetpaste-config-services services.conf
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}