summaryrefslogtreecommitdiff
path: root/app-text/webgen/webgen-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/webgen/webgen-1.7.2.ebuild')
-rw-r--r--app-text/webgen/webgen-1.7.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-text/webgen/webgen-1.7.2.ebuild b/app-text/webgen/webgen-1.7.2.ebuild
index 50a71eab42a2..f6e1b0bec434 100644
--- a/app-text/webgen/webgen-1.7.2.ebuild
+++ b/app-text/webgen/webgen-1.7.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_DOC="task"
RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
@@ -46,6 +46,9 @@ all_ruby_prepare() {
# Avoid tests failing with newer Psych versions
rm -f test/test_documentation.rb || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' $(find test -type f -print) || die
}
all_ruby_install() {