summaryrefslogtreecommitdiff
path: root/app-text/uudeview/uudeview-0.5.20-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/uudeview/uudeview-0.5.20-r2.ebuild')
-rw-r--r--app-text/uudeview/uudeview-0.5.20-r2.ebuild33
1 files changed, 13 insertions, 20 deletions
diff --git a/app-text/uudeview/uudeview-0.5.20-r2.ebuild b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
index 6331df769ce0..d8c47f134083 100644
--- a/app-text/uudeview/uudeview-0.5.20-r2.ebuild
+++ b/app-text/uudeview/uudeview-0.5.20-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="uu, xx, base64, binhex decoder"
HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
@@ -12,28 +12,21 @@ SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-DOCS=( HISTORY INSTALL README )
PATCHES=(
- "${FILESDIR}/${P}-bugfixes.patch"
- "${FILESDIR}/${P}-CVE-2004-2265.patch"
- "${FILESDIR}/${P}-CVE-2008-2266.patch"
- "${FILESDIR}/${P}-man.patch"
- "${FILESDIR}/${P}-rename.patch"
- "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}"/${P}-bugfixes.patch
+ "${FILESDIR}"/${P}-CVE-2004-2265.patch
+ "${FILESDIR}"/${P}-CVE-2008-2266.patch
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-rename.patch
+ "${FILESDIR}"/${P}-makefile.patch
)
-src_prepare() {
- epatch "${PATCHES[@]}"
-
- mv configure.in configure.ac || die
+DOCS=( HISTORY INSTALL README )
- epatch_user
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}