summaryrefslogtreecommitdiff
path: root/app-text/texi2html
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/texi2html')
-rw-r--r--app-text/texi2html/Manifest2
-rw-r--r--app-text/texi2html/texi2html-5.0-r1.ebuild30
2 files changed, 17 insertions, 15 deletions
diff --git a/app-text/texi2html/Manifest b/app-text/texi2html/Manifest
index 7479adfc39d7..deff832f4937 100644
--- a/app-text/texi2html/Manifest
+++ b/app-text/texi2html/Manifest
@@ -1,3 +1,3 @@
DIST texi2html-5.0.tar.bz2 15397249 BLAKE2B 3e502d9424c2936a922488aab7a66140c0a8369253a5500beeebcea0942ffa7b97fb7021b23212264e110d4bdab4850f263269aacf61de23ac6e052dfcf10d67 SHA512 50afc2f1f8875d3e62a51cc0339bd4c4f058041f42a9fda9cd5b02960f0d5c72838e4f010702ba716dbd256946f64520ce1e5b86539b6f7b8b7ce24a43c98e9d
-EBUILD texi2html-5.0-r1.ebuild 1331 BLAKE2B c8a945376b9170577369ab7a5779df032aa30f5fecd4e9a52937a0b18589309fc6f2a489e2172359fd94da40c0890c2c1553ad9bf491bc644170c7c52b95e4f4 SHA512 3fef0018328252c5156c1126affc72d2a0a3ee3d457b4837353e2c7584131705c27410547a0e7c52770b33b57b9c5557529313f5f22126c21e5ade832959d9e2
+EBUILD texi2html-5.0-r1.ebuild 1350 BLAKE2B e22201f81e83a95bd57ea071847011c9fbade332488b1f46fe77b9acb9de378f90e953f83249e4797745ffa1c371c7e2e7dcdfb026cee4725bfa549088b247c1 SHA512 85c7762bf4cedb41c4da6fe721e467b175ddf8b6b92f017d385adc81af8e8de7fb16fbd58d867abfa4667a1f1e48a657213bd0aecb4861f015dd384f28c5bbf9
MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/app-text/texi2html/texi2html-5.0-r1.ebuild b/app-text/texi2html/texi2html-5.0-r1.ebuild
index 81ea54fbe106..51e4bdab7d44 100644
--- a/app-text/texi2html/texi2html-5.0-r1.ebuild
+++ b/app-text/texi2html/texi2html-5.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit prefix
@@ -13,32 +13,34 @@ LICENSE="GPL-2+ || ( GPL-2 CC-BY-SA-1.0 ) Texinfo-manual LGPL-2+ MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="unicode"
+RESTRICT="test" #411523
-RDEPEND=">=dev-lang/perl-5.10.1
- >=dev-perl/libintl-perl-1.200
+RDEPEND="
+ dev-lang/perl
+ dev-perl/libintl-perl
unicode? (
dev-perl/Text-Unidecode
dev-perl/Unicode-EastAsianWidth
- )"
+ )"
DEPEND="${RDEPEND}"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-RESTRICT="test" #411523
-
src_prepare() {
+ default
+
# On FreeBSD this script is used instead of GNU install but it comes without
# executable pemissions... Fix it!
chmod +x install-sh || die
if use prefix; then
- hprefixify $(find . -name '*.pl' | xargs)
+ local f
+ while IFS="" read -d $'\0' -r f ; do
+ hprefixify "${f}"
+ done < <(find . -name '*.pl' -print0)
fi
}
src_configure() {
- local myconf
- use unicode && myconf='--with-external-Unicode-EastAsianWidth'
+ use unicode && local myconf='--with-external-Unicode-EastAsianWidth'
econf \
--with-external-libintl-perl \
@@ -48,9 +50,9 @@ src_configure() {
src_install() {
default
- rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
+ rm "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README} || die
}
pkg_preinst() {
- rm -f "${EROOT}"/usr/bin/${PN}
+ rm -f "${EROOT}"/usr/bin/${PN} || die
}