summaryrefslogtreecommitdiff
path: root/app-text/tesseract/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tesseract/files')
-rw-r--r--app-text/tesseract/files/tesseract-3.05.00-no_graphics.patch74
-rw-r--r--app-text/tesseract/files/tesseract-3.05.00-use-system-piccolo2d.patch27
2 files changed, 0 insertions, 101 deletions
diff --git a/app-text/tesseract/files/tesseract-3.05.00-no_graphics.patch b/app-text/tesseract/files/tesseract-3.05.00-no_graphics.patch
deleted file mode 100644
index d6250d66c056..000000000000
--- a/app-text/tesseract/files/tesseract-3.05.00-no_graphics.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 4141de7f8ddb5ac3c39fd9c1fc77ed911c768c3d Mon Sep 17 00:00:00 2001
-From: Bernard Cafarelli <bernard.cafarelli@gmail.com>
-Date: Fri, 27 Jan 2017 12:02:54 +0100
-Subject: [PATCH] Provide SVSync::StartThread() with GRAPHICS_DISABLED
-
----
- viewer/svutil.cpp | 44 +++++++++++++++++++++-----------------------
- 1 file changed, 21 insertions(+), 23 deletions(-)
-
-diff --git a/viewer/svutil.cpp b/viewer/svutil.cpp
-index 34a2286..84a4b94 100644
---- a/viewer/svutil.cpp
-+++ b/viewer/svutil.cpp
-@@ -83,6 +83,27 @@ void SVMutex::Unlock() {
- #endif
- }
-
-+// Create new thread.
-+void SVSync::StartThread(void *(*func)(void*), void* arg) {
-+#ifdef _WIN32
-+ LPTHREAD_START_ROUTINE f = (LPTHREAD_START_ROUTINE) func;
-+ DWORD threadid;
-+ HANDLE newthread = CreateThread(
-+ NULL, // default security attributes
-+ 0, // use default stack size
-+ f, // thread function
-+ arg, // argument to thread function
-+ 0, // use default creation flags
-+ &threadid); // returns the thread identifier
-+#else
-+ pthread_t helper;
-+ pthread_attr_t attr;
-+ pthread_attr_init(&attr);
-+ pthread_attr_setdetachstate(&attr, PTHREAD_CREATE_DETACHED);
-+ pthread_create(&helper, &attr, func, arg);
-+#endif
-+}
-+
- #ifndef GRAPHICS_DISABLED
-
- const int kMaxMsgSize = 4096;
-@@ -186,29 +207,6 @@ void SVSemaphore::Wait() {
- #endif
- }
-
--
--// Create new thread.
--
--void SVSync::StartThread(void *(*func)(void*), void* arg) {
--#ifdef _WIN32
-- LPTHREAD_START_ROUTINE f = (LPTHREAD_START_ROUTINE) func;
-- DWORD threadid;
-- HANDLE newthread = CreateThread(
-- NULL, // default security attributes
-- 0, // use default stack size
-- f, // thread function
-- arg, // argument to thread function
-- 0, // use default creation flags
-- &threadid); // returns the thread identifier
--#else
-- pthread_t helper;
-- pthread_attr_t attr;
-- pthread_attr_init(&attr);
-- pthread_attr_setdetachstate(&attr, PTHREAD_CREATE_DETACHED);
-- pthread_create(&helper, &attr, func, arg);
--#endif
--}
--
- // Place a message in the message buffer (and flush it).
- void SVNetwork::Send(const char* msg) {
- mutex_send_->Lock();
---
-2.12.0
-
diff --git a/app-text/tesseract/files/tesseract-3.05.00-use-system-piccolo2d.patch b/app-text/tesseract/files/tesseract-3.05.00-use-system-piccolo2d.patch
deleted file mode 100644
index ad1f0f3df208..000000000000
--- a/app-text/tesseract/files/tesseract-3.05.00-use-system-piccolo2d.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naur tesseract.orig/java/Makefile.am tesseract/java/Makefile.am
---- tesseract.orig/java/Makefile.am 2017-01-30 17:20:23.135458366 +0100
-+++ tesseract/java/Makefile.am 2017-01-30 17:21:29.834462557 +0100
-@@ -36,10 +36,9 @@
- com/google/scrollview/ScrollView.class
-
- SCROLLVIEW_LIBS = \
-- piccolo2d-core-3.0.jar \
-- piccolo2d-extras-3.0.jar
-+ /usr/share/piccolo2d/lib/piccolo2d.jar
-
--CLASSPATH = piccolo2d-core-3.0.jar:piccolo2d-extras-3.0.jar
-+CLASSPATH = /usr/share/piccolo2d/lib/piccolo2d.jar
-
- ScrollView.jar : $(SCROLLVIEW_CLASSES)
- $(JAR) cfm $@ $(srcdir)/Manifest.txt com/google/scrollview/*.class \
-diff -Naur tesseract.orig/viewer/Makefile.am tesseract/viewer/Makefile.am
---- tesseract.orig/viewer/Makefile.am 2017-01-30 17:20:23.176458368 +0100
-+++ tesseract/viewer/Makefile.am 2017-01-30 17:22:39.281467163 +0100
-@@ -17,3 +17,7 @@
-
- libtesseract_viewer_la_SOURCES = \
- scrollview.cpp svmnode.cpp svutil.cpp svpaint.cpp
-+
-+if !GRAPHICS_DISABLED
-+AM_CPPFLAGS += -DSCROLLVIEW_PATH=/usr/share/tessdata/
-+endif