summaryrefslogtreecommitdiff
path: root/app-text/tesseract/files/tesseract-3.05.00-libtiff.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tesseract/files/tesseract-3.05.00-libtiff.patch')
-rw-r--r--app-text/tesseract/files/tesseract-3.05.00-libtiff.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/tesseract/files/tesseract-3.05.00-libtiff.patch b/app-text/tesseract/files/tesseract-3.05.00-libtiff.patch
new file mode 100644
index 000000000000..5771739c3445
--- /dev/null
+++ b/app-text/tesseract/files/tesseract-3.05.00-libtiff.patch
@@ -0,0 +1,25 @@
+From 9ec0c4fa9c9836d414c02662a6f94f48815d61b2 Mon Sep 17 00:00:00 2001
+From: Stefan Weil <sw@weilnetz.de>
+Date: Tue, 13 Dec 2016 13:28:29 +0100
+Subject: [PATCH] api: Add missing dependency on libtiff
+
+It is needed because of a direct call to TIFFSetWarningHandler.
+
+Signed-off-by: Stefan Weil <sw@weilnetz.de>
+---
+ api/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/api/Makefile.am b/api/Makefile.am
+index 76a8ed4..25e7f21 100644
+--- a/api/Makefile.am
++++ b/api/Makefile.am
+@@ -90,6 +90,8 @@ tesseract_LDFLAGS = $(OPENCL_LDFLAGS)
+
+ tesseract_LDADD += $(OPENMP_CXXFLAGS)
+
++tesseract_LDADD += -ltiff
++
+ if T_WIN
+ tesseract_LDADD += -lws2_32
+ libtesseract_la_LDFLAGS += -no-undefined -Wl,--as-needed -lws2_32