summaryrefslogtreecommitdiff
path: root/app-text/qpdf/qpdf-9.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/qpdf/qpdf-9.0.2-r1.ebuild')
-rw-r--r--app-text/qpdf/qpdf-9.0.2-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-text/qpdf/qpdf-9.0.2-r1.ebuild b/app-text/qpdf/qpdf-9.0.2-r1.ebuild
deleted file mode 100644
index 81bb26e22d5c..000000000000
--- a/app-text/qpdf/qpdf-9.0.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
-HOMEPAGE="http://qpdf.sourceforge.net/"
-SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 Artistic-2 )"
-
-# subslot = libqpdf soname version
-SLOT="0/26"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris"
-IUSE="doc examples perl static-libs test"
-
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- sys-libs/zlib
- virtual/jpeg:0=
-"
-DEPEND="${CDEPEND}
- test? (
- sys-apps/diffutils
- media-libs/tiff
- app-text/ghostscript-gpl[tiff(+)]
- )
-"
-# Only need perl for the installed tools.
-RDEPEND="${CDEPEND}
- perl? ( >=dev-lang/perl-5.8 )
-"
-
-DOCS=( ChangeLog README.md TODO )
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable test test-compare-images)
- )
- CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if ! use perl ; then
- rm "${ED}"/usr/bin/fix-qdf || die
- rm "${ED}"/usr/share/man/man1/fix-qdf.1 || die
- fi
-
- if use examples ; then
- dobin examples/build/.libs/*
- fi
-
- find "${ED}" -name '*.la' -delete || die
-}