summaryrefslogtreecommitdiff
path: root/app-text/pytextile
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pytextile')
-rw-r--r--app-text/pytextile/Manifest4
-rw-r--r--app-text/pytextile/metadata.xml1
-rw-r--r--app-text/pytextile/pytextile-4.0.1.ebuild35
3 files changed, 15 insertions, 25 deletions
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index 7a2ebd5498a5..aa46b348ad09 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1,3 +1,3 @@
DIST pytextile-4.0.1.tar.gz 49282 BLAKE2B b51220ff33fe43b83d0aefee840b5170747015073fbe88934798c2505c3455e9805eee8815ec8068521c88a44a309bd0eb32e84757d088536f1c12a1f9bc0ca0 SHA512 e299663fd71b935e9c948649baba80584b1339dd3393a3f37b39475fe1d6a4addaaa2adcd16ba57b4c5db43ab9f8de6e9332871915b1fff7b7882ad5e8d64580
-EBUILD pytextile-4.0.1.ebuild 1215 BLAKE2B df2236630c1210a841998c67aae0d95c42f7d48f68a38fc2696a0c5d141e8ecab24dc3e2ad99e31b61111523ab6fa1564d6662dce13da50cb598b2e47c109b60 SHA512 f0d5c43bd329be36fd304fb3f2d1517d7eb1102ae8b456290d4097c46cc90b87247d0f8064e57b514ac81bba01023be50b4ffe7893143e339ffbe7eabed50491
-MISC metadata.xml 554 BLAKE2B 014b0bb6fd9f0405aca39429a804bf9b3c2ff7dfcbcf55aab6678298c1ce37093c2c0005c315467cbec5c19b1f7da020c8eaabc1d912fd7b5d93567f62c94fff SHA512 6d4de4859070958c55f816ee8692a33f1a7b70de38549e9a6242044ccfdfffc590da29c79c450862537185fe2803bb0e09b2bb46ea76cf5548a2ded01a26434f
+EBUILD pytextile-4.0.1.ebuild 1008 BLAKE2B 07616901906c397bd0fd24dea136ee5f35ff1109e7a831513532e1f459c5a80af15fb006934e8e55f17cd3ba5135a6c04b3f54c944b33e369316444f98bdf193 SHA512 956ff98bc2e9b1512fda6b504845a82bec1dc82092915e81fe83af4be2a70a315d7db6fab763faa4bfabf8591f1b9798b67ccbfaa75a7240cabf5669eba13c77
+MISC metadata.xml 579 BLAKE2B c30b2a45deff98fe7dd2ff8c9080845767b6369868a07c73ca2a9c4ab0553e0dd7d3d5d895eefb57626d066684e7e196268cf39fc7c4ee4207204a0a9b7dcabd SHA512 a919aefd9ad046bc9615fcc9fe9a11768fe023fdf8fa18b9debd762c3ed74362feebbb458b9dca0880d86bbe753e17c3287bc504030cf79c51b98f501b3d9402
diff --git a/app-text/pytextile/metadata.xml b/app-text/pytextile/metadata.xml
index c752a82be216..08d54e0cbc16 100644
--- a/app-text/pytextile/metadata.xml
+++ b/app-text/pytextile/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<longdescription lang="en">A Python implementation of Textile, Dean Allen's Human Text Generator.
Textile simplifies the work of creating (X)HTML.</longdescription>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">textile</remote-id>
<remote-id type="github">textile/python-textile</remote-id>
diff --git a/app-text/pytextile/pytextile-4.0.1.ebuild b/app-text/pytextile/pytextile-4.0.1.ebuild
index ffa9cd0eb2eb..fc7f0aecbd1d 100644
--- a/app-text/pytextile/pytextile-4.0.1.ebuild
+++ b/app-text/pytextile/pytextile-4.0.1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-MY_PN="python-textile"
-MY_P="${MY_PN}-${PV}"
+MY_P="python-textile-${PV}"
DESCRIPTION="A Python port of Textile, A humane web text generator"
HOMEPAGE="https://github.com/textile/python-textile"
@@ -17,39 +15,30 @@ SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/regex[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
S="${WORKDIR}/${MY_P}"
+distutils_enable_tests pytest
+
src_prepare() {
default
# remove useless --cov arg injection
rm pytest.ini || die
# remove useless pytest-runner dep
sed -e "s/pytest-runner//g" -i setup.py || die
-
- # remove tests that need network access
- local my_drop_tests=(
- test_getimagesize.py
- test_imagesize.py
- test_textile.py
- )
- for test in ${my_drop_tests[@]};
- do rm "tests/$test" || die
- done
}
python_test() {
- pytest || die "Testsuite failed under ${EPYTHON}"
+ local deselect=(
+ # tests that need network access
+ tests/test_getimagesize.py
+ tests/test_imagesize.py
+ tests/test_textile.py
+ )
+ epytest ${deselect[@]/#/--deselect }
}