summaryrefslogtreecommitdiff
path: root/app-text/pytextile/pytextile-2.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pytextile/pytextile-2.1.8.ebuild')
-rw-r--r--app-text/pytextile/pytextile-2.1.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-2.1.8.ebuild b/app-text/pytextile/pytextile-2.1.8.ebuild
new file mode 100644
index 000000000000..583464ba033b
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.1.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/ikirudennis/python-textile"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${P}-sanitizer.patch )
+
+python_prepare_all() {
+ # This resolves a nasty race condition noted and observed by Arfrever
+ sed -e 's:with-id = 1::' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests textile/tests/ || die "Tests failed under ${EPYTHON}"
+}