summaryrefslogtreecommitdiff
path: root/app-text/poppler
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/Manifest4
-rw-r--r--app-text/poppler/poppler-21.08.0.ebuild126
-rw-r--r--app-text/poppler/poppler-9999.ebuild4
3 files changed, 131 insertions, 3 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index a2c51d7f963a..ae84213a48b9 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,6 +2,8 @@ AUX poppler-0.57.0-disable-internal-jpx.patch 892 BLAKE2B 811ce3bbeb3b3c0720902a
AUX poppler-20.12.1-qt5-deps.patch 1626 BLAKE2B 7dfd227e1e8d4449e0cc72ca297afa78b58e97dea19fe7f72bc65a599890db586dcb46780b3c737e2c2723749cf53078fddf565aa58bec0cbf553993d18bb6ce SHA512 286ddcae2bb639107f3d3ffab9317b10c437014d466efc8e39407d6350acc77900ee60888863b9dfa95c546c39b5b7f1a97a8936a4ac3ed7c6b2a30666eee537
AUX poppler-21.04.0-respect-cflags.patch 5738 BLAKE2B d09ed8ca5211b89a06b56d8e7f3564ca6b388f36469d174444a5b974ef0403e55061900b79049ad9192a0a5e2baa0bee295904c3ea27a74dfba7eb8813501600 SHA512 f9f915f3343f42f504080320fb1e35164f489abfa55bd7bc0889dffe05db56f49c8a528bc253e315e5616e6baccb413710a562021538ad4fa7f081b673bc688b
DIST poppler-21.07.0.tar.xz 1709664 BLAKE2B 22c411c44a7f61344a0ea747fd435ad2b0180979d8117425167338b7f5cf963eefac19d38b5630df03b4ef978a113c9f031966d3bd8b0c1d86a5bdecd526d191 SHA512 ce1d8a5dd4a300a24aa71aea4919262e108ce1717dee04863da41de0962e4c0067e9c703c190386bd66d9c4ef54d04513cc8509f4beaf76e996576912d2583e8
+DIST poppler-21.08.0.tar.xz 1717372 BLAKE2B f617b41ebacee183730f20233273a2cc773c12b6c9d045850f8e738985b9079338c0e86b66d598a5dd4fd0227f70989604164a38fd45150b239e603c4da7e42f SHA512 266583279fb5c6b5300d23f8ba5b9da3e1f475fe21341a82ed7350dd9e321e243f3ef051944006c4f242c2d63a8c46bcda565a56017eb3a68caa5680ce719211
EBUILD poppler-21.07.0.ebuild 3339 BLAKE2B fa5a0f1aee4edc405149d5573b917320eb8748054687222ba9dab6c61105af7286022bfc7d7b685aff174966a7d0db1274dddf9464343fd4e35a4dd6d5c53921 SHA512 c0f8caf6a63c76024c668e8f98cdb67ddd5ff3a0798cd54d1276a1aecae54324dcbbd291e308a4e322eefa61ff13a34027fe86bbd9f464a8fc9873da6a41af48
-EBUILD poppler-9999.ebuild 3340 BLAKE2B 916235fb20cb98652c0f5fe4f738b513d8a987e2f9c94965ebdf7a7b284b2f317977f0cd43c2cfb0786db4b5bf90ec659dbd7f7b0ba401a63d139c892a396ec0 SHA512 17b37f071e8136c0b8be0924909e5000ff7f36af97e8917b282ba08536aedd6c1bf32674be101e48585a5e4744e36238565bae7fe73f96c323abeb816f39cb54
+EBUILD poppler-21.08.0.ebuild 3347 BLAKE2B 700214c4ab1e71cc530bb084915ffdae2dbb4b56a30eed2ae599c0bf8f71fc03f5357ab105c41123c075397743ee86b0cc920b0356c642ca7e4ad1ccc663e293 SHA512 2964d203250ad578b09895582fdf02e855b2355944bc318384db76d39701582233382c436f9d2f22e643a88db98dc891070edabe3a11c94614ace4fc224cfb95
+EBUILD poppler-9999.ebuild 3347 BLAKE2B 700214c4ab1e71cc530bb084915ffdae2dbb4b56a30eed2ae599c0bf8f71fc03f5357ab105c41123c075397743ee86b0cc920b0356c642ca7e4ad1ccc663e293 SHA512 2964d203250ad578b09895582fdf02e855b2355944bc318384db76d39701582233382c436f9d2f22e643a88db98dc891070edabe3a11c94614ace4fc224cfb95
MISC metadata.xml 1077 BLAKE2B c49251ca6f1d793da24746e5161d43b01550c560fb942d64298c19a889c531f4c5fab967cde87f7063ecb4789a6586e40ca519b196633912ccb55ed568a650cf SHA512 c09156d438acc9cf85e77fd1f57262596c28f305559d9635d4a457189f88e56e0689e102ad60d2be998b9e286c36ed45227e95ae5e9ce6a247662331d44f2076
diff --git a/app-text/poppler/poppler-21.08.0.ebuild b/app-text/poppler/poppler-21.08.0.ebuild
new file mode 100644
index 000000000000..be72663ad68d
--- /dev/null
+++ b/app-text/poppler/poppler-21.08.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 2005-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/112" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ introspection? ( dev-libs/gobject-introspection:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND+="
+ boost? ( dev-libs/boost )
+"
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
+ "${FILESDIR}/${PN}-21.04.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DBUILD_MANUAL_TESTS=OFF
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ -DENABLE_QT6=OFF
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index a7d99002f542..be72663ad68d 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -11,8 +11,8 @@ if [[ ${PV} == *9999* ]] ; then
SLOT="0/9999"
else
SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/111" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/112" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"