summaryrefslogtreecommitdiff
path: root/app-text/podofo/podofo-0.10.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/podofo/podofo-0.10.1-r1.ebuild')
-rw-r--r--app-text/podofo/podofo-0.10.1-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-text/podofo/podofo-0.10.1-r1.ebuild b/app-text/podofo/podofo-0.10.1-r1.ebuild
index 01677dd282b6..03852080e471 100644
--- a/app-text/podofo/podofo-0.10.1-r1.ebuild
+++ b/app-text/podofo/podofo-0.10.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake flag-o-matic
+inherit cmake
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format"
HOMEPAGE="https://github.com/podofo/podofo"
@@ -37,6 +37,13 @@ BDEPEND="
test? ( fontconfig? ( media-fonts/liberation-fonts ) )
"
+PATCHES=(
+ # Dome optimizations cause testsuite failures due to floating point
+ # contraction. Fixed upstream by adding tolerance to the test itself:
+ # https://github.com/podofo/podofo/issues/103
+ "${FILESDIR}"/0001-FIX-ColorTest-Fixed-test-under-linux-when-compiled-w.patch
+)
+
src_prepare() {
cmake_src_prepare
if use test; then
@@ -56,11 +63,6 @@ src_configure() {
$(cmake_use_find_package fontconfig Fontconfig)
)
- # some optimizations cause testsuite failures which may indicate
- # unsoundness with contraction. Be cautious for now. Reported
- # upstream as https://github.com/podofo/podofo/issues/103
- append-cxxflags $(test-flags-CXX -ffp-contract=off)
-
cmake_src_configure
}