summaryrefslogtreecommitdiff
path: root/app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch')
-rw-r--r--app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch b/app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch
new file mode 100644
index 000000000000..f178ae2a6c0c
--- /dev/null
+++ b/app-text/podofo/files/podofo-0.9.6_p20190928-cmake_lua_version.patch
@@ -0,0 +1,15 @@
+Switch from the non-standard upstream CMake Lua module to the one bundled
+with CMake, use only the Lua version requested by the ebuild, and do not
+semi-quietly ignore the absence of Lua.
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -433,7 +433,7 @@
+ ENDIF(WANT_FONTCONFIG)
+
+ IF(NOT PODOFO_BUILD_LIB_ONLY)
+-FIND_PACKAGE(LUA)
++FIND_PACKAGE(Lua ${LUA_VERSION} EXACT REQUIRED)
+ IF(LUA_FOUND)
+ # If we have lua, we can build podofoimpose.
+ MESSAGE("Lua found - PoDoFoImpose and PoDoFoColor will be built with Lua support")