summaryrefslogtreecommitdiff
path: root/app-text/nfoview/nfoview-1.27.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/nfoview/nfoview-1.27.ebuild')
-rw-r--r--app-text/nfoview/nfoview-1.27.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/nfoview/nfoview-1.27.ebuild b/app-text/nfoview/nfoview-1.27.ebuild
new file mode 100644
index 000000000000..3229ddf95d7a
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}