summaryrefslogtreecommitdiff
path: root/app-text/msort/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/msort/files')
-rw-r--r--app-text/msort/files/msort-8.53-find-utf8proc-headers.patch33
-rw-r--r--app-text/msort/files/msort-8.53-fix-icu-build.patch11
-rw-r--r--app-text/msort/files/msort-8.53-fix-missing-limits-header.patch11
-rw-r--r--app-text/msort/files/msort-8.53-fix-segfault-on-certain-input.patch11
-rw-r--r--app-text/msort/files/msort-8.53-respect-users-cflags.patch11
5 files changed, 77 insertions, 0 deletions
diff --git a/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch b/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch
new file mode 100644
index 000000000000..9b3845bc601c
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch
@@ -0,0 +1,33 @@
+--- a/configure.ac 2010-01-11 01:56:36.000000000 +0100
++++ b/configure.ac 2018-09-27 15:05:20.205734233 +0200
+@@ -94,7 +94,7 @@
+ AC_CHECK_HEADERS([alloca.h ctype.h errno.h gnu/libc-version.h langinfo.h libintl.h limits.h locale.h stdargs.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/stat.h time.h tre/tre.h unicode/umachine.h unicode/unorm.h uninum/unicode.h uninum/nsdefs.h uninum/uninum.h unistd.h wchar.h wctype.h])
+
+ if ${utf8proc}; then
+-AC_CHECK_HEADER([utf8proc.h],[AC_DEFINE([HAVE_UTF8PROC_H], [1],[Define to 1 if you have <utf8proc.h>.])],[AC_MSG_ERROR([LIB UTF8PROC and its header is obligatory. See http://www.flexiguided.de/publications.utf8proc.en.html])])
++AC_CHECK_HEADER([libutf8proc/utf8proc.h],[AC_DEFINE([HAVE_UTF8PROC_H], [1],[Define to 1 if you have <libutf8proc/utf8proc.h>.])],[AC_MSG_ERROR([LIB UTF8PROC and its header is obligatory. See http://www.flexiguided.de/publications.utf8proc.en.html])])
+ fi
+
+ if ${uninum}; then
+--- a/misc.c 2009-08-05 05:09:21.000000000 +0200
++++ b/misc.c 2018-09-27 15:10:37.355738021 +0200
+@@ -41,7 +41,7 @@
+ #include <unicode/umachine.h>
+ #include <unicode/unorm.h>
+ #else
+-#include <utf8proc.h>
++#include <libutf8proc/utf8proc.h>
+ #include "unorm.h"
+ #endif
+ #include <tre/regex.h>
+--- a/msort.c 2010-01-11 01:53:32.000000000 +0100
++++ b/msort.c 2018-09-27 15:10:30.275737936 +0200
+@@ -57,7 +57,7 @@
+ #ifndef USEUTF8PROC
+ #include <unicode/unorm.h>
+ #else
+-#include <utf8proc.h>
++#include <libutf8proc/utf8proc.h>
+ #include "unorm.h"
+ #endif
+ #ifdef HAVE_UNINUM_UNICODE_H
diff --git a/app-text/msort/files/msort-8.53-fix-icu-build.patch b/app-text/msort/files/msort-8.53-fix-icu-build.patch
new file mode 100644
index 000000000000..658be287e5ee
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-fix-icu-build.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am 2009-08-05 05:09:21.000000000 +0200
++++ b/Makefile.am 2018-09-27 15:41:10.685759919 +0200
+@@ -22,7 +22,7 @@
+ LIBS+=-lutf8proc
+ AM_CFLAGS += -DUSEUTF8PROC
+ else
+-LIBS+=-licutu
++LIBS+=-licutu -licuuc
+ endif
+
+ msg: msg.tcl
diff --git a/app-text/msort/files/msort-8.53-fix-missing-limits-header.patch b/app-text/msort/files/msort-8.53-fix-missing-limits-header.patch
new file mode 100644
index 000000000000..14459d1cfd24
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-fix-missing-limits-header.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.am 2009-08-05 05:09:21.000000000 +0200
++++ b/Makefile.am 2018-09-27 15:32:28.685753684 +0200
+@@ -6,7 +6,7 @@
+ noinst_HEADERS = comparisons.h compdefs.h dstr.h ex_codes.h exitcode.h input.h key.h limits.h record.h retcodes.h unicode.h unorm.h utf8error.h
+ LOCALEDIR=/usr/local/share/locale
+ EXTRA_DIST = $(docs) msg.tcl CREDITS msort-${VERSION}.lsm RegressionTests SortOrders
+-AUTOMAKE_OPTIONS = dist-zip dist-bzip2
++AUTOMAKE_OPTIONS = dist-zip dist-bzip2 nostdinc
+
+ if ALLOCAOK
+ AM_CFLAGS = -DLOCALEDIR=\"${LOCALEDIR}\" -DALLOCAOK -std=gnu99
diff --git a/app-text/msort/files/msort-8.53-fix-segfault-on-certain-input.patch b/app-text/msort/files/msort-8.53-fix-segfault-on-certain-input.patch
new file mode 100644
index 000000000000..01edc69eb7da
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-fix-segfault-on-certain-input.patch
@@ -0,0 +1,11 @@
+--- a/dstr.c 2009-08-05 05:09:21.000000000 +0200
++++ b/dstr.c 2018-09-27 15:43:52.815761856 +0200
+@@ -79,7 +79,7 @@
+ #ifdef SAFECALL
+ if(length == 0) return(ERROR);
+ #endif
+- if (length > tgt->c) {
++ if (length + 1 > tgt->c) {
+ if(tgt->s != NULL) free( (void *) tgt->s);
+ tgt->s = (wchar_t *) malloc((length + 1) * sizeof(wchar_t));
+ if(tgt->s == NULL) return(ERROR);
diff --git a/app-text/msort/files/msort-8.53-respect-users-cflags.patch b/app-text/msort/files/msort-8.53-respect-users-cflags.patch
new file mode 100644
index 000000000000..aefe84772447
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-respect-users-cflags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2010-01-11 01:56:36.000000000 +0100
++++ b/configure.ac 2018-09-27 15:36:41.425756703 +0200
+@@ -78,8 +78,6 @@
+ AC_PROG_CC
+ if ${debugbuild}; then
+ CFLAGS="-ggdb -g3"
+-else
+- CFLAGS="-g -O2"
+ fi
+
+ AC_PROG_INSTALL