summaryrefslogtreecommitdiff
path: root/app-text/linuxdoc-tools
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/linuxdoc-tools')
-rw-r--r--app-text/linuxdoc-tools/Manifest1
-rw-r--r--app-text/linuxdoc-tools/linuxdoc-tools-0.9.73-r1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-text/linuxdoc-tools/Manifest b/app-text/linuxdoc-tools/Manifest
index 23265a98edf8..266d4901fcc0 100644
--- a/app-text/linuxdoc-tools/Manifest
+++ b/app-text/linuxdoc-tools/Manifest
@@ -1,5 +1,6 @@
DIST linuxdoc-tools-0.9.72.tar.gz 614429 BLAKE2B 404b311c0560780bd81f021760d32e47cd6ebe8abc9aa64a181b8ce727dd0edbbd88d286cdfdcc97a51981bd0bd299563d7b1b2945e06f83ff32c7d3e56abb19 SHA512 2d522a99212dab2535786b64e0b404a9bb023d1612d8e57a628de21b5e77b104285713a98591c61a2fb2196e687b34180198ab0dfeda2b44fbbce051e9919408
DIST linuxdoc-tools-0.9.73.tar.gz 613971 BLAKE2B e2e04aaa44d5e2cea5af266e38b476381f87a02b9704e03ae5943f7714634d5d214350abd5b193f2efe656a264403c679495af5f954870b30d32b8b799ad7206 SHA512 b26896316e259cf4ef170814d410b1e39e58f61db49b03b4b9c1f767f8459d84214e92d9dcc09ad739508fd9c3c5fe4a2264cbb3c693a11362e59fd221655252
EBUILD linuxdoc-tools-0.9.72.ebuild 1777 BLAKE2B b61585eaf79a55b9acc1f4711cbaec19d421db998f091a4fb5827292bb30c5720de9ba5a300ad0cf248b509a8ec4d1a0415a4ee498edb18f49279cf673ff35cb SHA512 40632a82dc9252a4bac966174c4e87f6f1adf075fb2ef125ea07ccc5796b98e74d8823d1afff11f98e042ded4eb5b7da82a8b8c5ab052e4f7d53357b84cbf649
+EBUILD linuxdoc-tools-0.9.73-r1.ebuild 1915 BLAKE2B a693c89988854a7efdabb270efd5d9ed3fd9888d6732b8cfe875cb9f34ca31a3f6718e090957f51ebc55a1a753cdadfac86eabb8e95a276f0a706b05f8b2366d SHA512 a8dc786ba14a8a89a5c05fe45bfa2e2deff57530a9235877791a6d9240a4e6ffc4871bbf6946ee497097fff6053c1af5f397e4362930ff4e4772147c96f0bb55
EBUILD linuxdoc-tools-0.9.73.ebuild 1667 BLAKE2B 7610425455383b2de6e6d2192b1efe2ff91f177cb7d57db0244c7a5318bff2676e52b383c973345797b4322ef6d67166ef6376d7d3d2eac14a17137b59d0ef41 SHA512 1cc1811a713b4b255daf959fb45294ce2aff9c97a6c8b8fefbe0ef4d229da09c98ea4be56087b0a185ad6fde30788ee6b578c72e3f2c82673918233581c0b726
MISC metadata.xml 911 BLAKE2B a78b50af9faf588a872f75b94f1278ce1ef5e16edb8c6f6c953dcc29b466be53f70a63275e5df54bd46f58d726e80f07b8cd8ae051d93f7c6ee11f0c8e63b8fe SHA512 6afd802552b700006b38a5eee516e5e1f59d0af0dff294bc2807804f8a85823ca2c5a928c0cfe2d5ef74d8c34521ecdd2a54d4ff5a1d322f17d42a6e5e6ad0f4
diff --git a/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73-r1.ebuild b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73-r1.ebuild
new file mode 100644
index 000000000000..4f2129a2644a
--- /dev/null
+++ b/app-text/linuxdoc-tools/linuxdoc-tools-0.9.73-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools latex-package perl-functions sgml-catalog-r1 toolchain-funcs
+
+DESCRIPTION="A toolset for processing LinuxDoc DTD SGML files"
+HOMEPAGE="https://gitlab.com/agmartin/linuxdoc-tools"
+SRC_URI="https://gitlab.com/agmartin/linuxdoc-tools/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ MIT SGMLUG"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="
+ || ( app-text/openjade app-text/opensp )
+ app-text/sgml-common
+ dev-lang/perl:=
+ sys-apps/groff
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/awk
+ doc? (
+ dev-texlive/texlive-fontsrecommended
+ virtual/latex-base
+ )
+"
+
+src_prepare() {
+ default_src_prepare
+ # Pregenerated configure scripts fail.
+ eautoreconf
+}
+
+src_configure() {
+ perl_set_version
+ tc-export CC
+ local myeconfargs=(
+ --disable-docs
+ --with-texdir="${TEXMF}/tex/latex/${PN}"
+ --with-perllibdir="${VENDOR_ARCH}"
+ --with-installed-iso-entities
+ )
+ use doc && myeconfargs+=(--enable-docs="txt pdf html")
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Prevent access violations from bitmap font files generation.
+ use doc && export VARTEXFONTS="${T}/fonts"
+ default_src_compile
+}
+
+src_install() {
+ # Makefile ignores docdir configuration option.
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}" install
+ dodoc ChangeLog README
+
+ insinto /etc/sgml
+ newins - linuxdoc.cat <<-EOF
+ CATALOG "${EPREFIX}/usr/share/linuxdoc-tools/linuxdoc-tools.catalog"
+ EOF
+}
+
+pkg_preinst() {
+ # work around sgml-catalog.eclass removing it
+ cp "${ED}"/etc/sgml/linuxdoc.cat "${T}" || die
+}
+
+pkg_postinst() {
+ if [[ ! -f ${EROOT}/etc/sgml/linuxdoc.cat ]]; then
+ cp "${T}"/linuxdoc.cat "${EROOT}"/etc/sgml/ || die
+ fi
+
+ latex-package_pkg_postinst
+ sgml-catalog-r1_pkg_postinst
+}
+
+pkg_postrm() {
+ latex-package_pkg_postrm
+ sgml-catalog-r1_pkg_postrm
+}