summaryrefslogtreecommitdiff
path: root/app-text/libwps/libwps-0.4.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwps/libwps-0.4.13.ebuild')
-rw-r--r--app-text/libwps/libwps-0.4.13.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/libwps/libwps-0.4.13.ebuild b/app-text/libwps/libwps-0.4.13.ebuild
new file mode 100644
index 000000000000..4737dd0f497e
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="debug doc tools"
+
+DEPEND="dev-libs/librevenge"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}