summaryrefslogtreecommitdiff
path: root/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libexttextcat/libexttextcat-3.4.5.ebuild')
-rw-r--r--app-text/libexttextcat/libexttextcat-3.4.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/libexttextcat/libexttextcat-3.4.5.ebuild b/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
new file mode 100644
index 000000000000..126ef36d1431
--- /dev/null
+++ b/app-text/libexttextcat/libexttextcat-3.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library implementing N-gram-based text categorization"
+HOMEPAGE="http://software.wise-guys.nl/libtextcat/"
+SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}