summaryrefslogtreecommitdiff
path: root/app-text/htp/htp-1.19-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/htp/htp-1.19-r1.ebuild')
-rw-r--r--app-text/htp/htp-1.19-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/htp/htp-1.19-r1.ebuild b/app-text/htp/htp-1.19-r1.ebuild
new file mode 100644
index 000000000000..c01e19b48e7d
--- /dev/null
+++ b/app-text/htp/htp-1.19-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An HTML preprocessor"
+HOMEPAGE="http://htp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.19-no-prestrip.patch
+ "${FILESDIR}"/${PN}-1.19-parallel-make.patch
+ "${FILESDIR}"/${PN}-1.19-fix-perl-5.26.patch
+)
+
+src_compile() {
+ # TOOD: Tests are always run by the Makefile right now
+ emake \
+ CCOPT="-c ${CFLAGS} ${CPPFLAGS} -DHAVE_SNPRINTF -DHAVE_VASPRINTF -DHAVE_ASPRINTF" \
+ CC="$(tc-getCC)" \
+ LINK='$(CC) $(LDFLAGS)'
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix='$(DESTDIR)/usr' \
+ pkgdocdir='$(DESTDIR)/usr/share/doc/${PF}/html' \
+ install
+}