summaryrefslogtreecommitdiff
path: root/app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch')
-rw-r--r--app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch b/app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch
new file mode 100644
index 000000000000..476db036730f
--- /dev/null
+++ b/app-text/htmltidy/files/htmltidy-5.8.0-no_static_lib.patch
@@ -0,0 +1,37 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -393,34 +393,7 @@
+ endif ()
+
+
+-#------------------------------------------------------------------------
+-# Static Library
+-# The static library always builds.
+-#------------------------------------------------------------------------
+-set(name tidy-static)
+-add_library ( ${name} STATIC ${CFILES} ${HFILES} ${LIBHFILES} )
+-if (WIN32)
+- set_target_properties( ${name} PROPERTIES
+- OUTPUT_NAME ${LIB_NAME}_static )
+-else ()
+- set_target_properties( ${name} PROPERTIES
+- OUTPUT_NAME ${LIB_NAME} )
+-
+-endif ()
+-if (NOT TIDY_CONSOLE_SHARED) # user wants default static linkage
+- list ( APPEND add_LIBS ${name} )
+-endif ()
+-install(TARGETS ${name}
+- RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+- ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+- LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+- )
+ install( FILES ${HFILES} DESTINATION ${INCLUDE_INSTALL_DIR} )
+-if(MSVC)
+- # install(FILES $<TARGET_PDB_FILE:${name}> DESTINATION lib OPTIONAL)
+- INSTALL(FILES ${PROJECT_BINARY_DIR}/${name}.dir/Debug/${name}.pdb
+- DESTINATION lib CONFIGURATIONS Debug )
+-endif()
+
+ #------------------------------------------------------------------------
+ # Dynamic Library