summaryrefslogtreecommitdiff
path: root/app-text/htmlmin
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/htmlmin')
-rw-r--r--app-text/htmlmin/Manifest2
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12-r3.ebuild (renamed from app-text/htmlmin/htmlmin-0.1.12-r1.ebuild)11
2 files changed, 8 insertions, 5 deletions
diff --git a/app-text/htmlmin/Manifest b/app-text/htmlmin/Manifest
index 2120d7457994..d8bc814fb697 100644
--- a/app-text/htmlmin/Manifest
+++ b/app-text/htmlmin/Manifest
@@ -1,3 +1,3 @@
DIST htmlmin-0.1.12.gh.tar.gz 134130 BLAKE2B 5a9996bfea469f273c37bd0bd72c0e27b8636cb4552681de1b7e9a4849ab215815f7fc8ce430392b8ca3a849b3e51d8188ca248a8ce23242905799258ceeae29 SHA512 6d9db4b6bcdd6d223be8b4e3830da4d63ac6d7d28ee83abd97809b0b901968c994c8434c992fbdd148101ba25d8d786c93657cb5f82881af44dadbba40bf3252
-EBUILD htmlmin-0.1.12-r1.ebuild 726 BLAKE2B 896e4a1d27ee383e67d6675a2aa6fcffe48a1e63cd72c3db431530fdf91cb253015be18cd99a26d44b77a8e8cecf65d66abd095f1a3ddb37ed199d46518681a4 SHA512 4e2388a91817094b2ab5a218b2d8f031d353890d225e2d3656a3b7d51c4a9fa6c1f35dfb5582b1bdf61468c153babb4420a86f65bfa4c4165a9eb0816cec816f
+EBUILD htmlmin-0.1.12-r3.ebuild 790 BLAKE2B 74d886dc5a43513ae93d7ec26b74531cf53ab7681f637bd1184fcc1a46bdcea75421f77561c2e5b8f5a8901015e4a662ac61d134d2c23c5ff5832957dfa7d880 SHA512 193c00a7ebe5ef77b00b3b7295c6f9c6893212157107331ff60e7f202879e2b4133bd0812531319d8753256a3457ae11c29fa7a2f311bea3a05d91c3b7e8ea80
MISC metadata.xml 503 BLAKE2B 120b7dfe5ecbbdf5b28ac559893d991071c39a34644aa6556abbf8c58c91f908003240f647ccbf58d6e1e776130e72a95bae033a07272ad213673960217acd9e SHA512 dbd48a6b9caca3a7c2e4789653c133321a6e42da5cde9b552c527d5afde0e0c7c0ee25a4712822a4bc1768424c0e3d7216f6d56a24899f2f0aed0b6a20bee61e
diff --git a/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild b/app-text/htmlmin/htmlmin-0.1.12-r3.ebuild
index c57dc344d252..188d0350d718 100644
--- a/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
+++ b/app-text/htmlmin/htmlmin-0.1.12-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1
@@ -21,9 +21,12 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
src_prepare() {
- sed '/prune/d' -i MANIFEST.in || die
distutils-r1_src_prepare
+
+ sed -i -e '/prune/d' MANIFEST.in || die
+ # unused import
+ sed -i -e '/cgi/d' htmlmin/main.py || die
}