summaryrefslogtreecommitdiff
path: root/app-text/html401
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/html401')
-rw-r--r--app-text/html401/Manifest1
-rw-r--r--app-text/html401/html401-19991224-r3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/html401/Manifest b/app-text/html401/Manifest
index 5d4841369b4b..a8a598ca0188 100644
--- a/app-text/html401/Manifest
+++ b/app-text/html401/Manifest
@@ -1,4 +1,5 @@
AUX html401-decl.diff 469 BLAKE2B 7b7e98352b9650b06fa7c9e792e1538873827ffd8d7c043d45a3035c1c1099be9c2aed632717f959a92b2b5f0dc646104c81f13fe612cbcabb3531afcf3d4b9a SHA512 066d1c3672e2b8fd86a696c511c4eab92c8772f147503a986f6c89d1c33720325d15c22157c81d7f121ee441328b89f73a194d5e7e40af4408b0f9b8e0cc65d2
DIST html40.tgz 369830 BLAKE2B c6fc0f65a9c65df34f534ce1db3cc53ba6ded4481df78f168c1b05b7e3b81fad7ddf3ee519ff1a901f0256af89285eefb39400ebc5b4089c1a16dfe935c6cf21 SHA512 f7423b55f8a5ad2806555700f450e1f46ba4370d1e47f1332e18b01ecd5a41217fc4426ad29c852b6e17100dc4c0a7add9961df35e87660df0e087ad03e4918e
EBUILD html401-19991224-r2.ebuild 751 BLAKE2B 88342ff6cbbeb2e0fcd389456bc469ab1c8470ffbad80cb6761f8bfd0a4a94884fbea9a3fb3e418944a08d353b59cc0bfdcc788001924a039b30acb7fc5df928 SHA512 48f9954963d403399bcb63dc18fa24ea36b28fa0d79f3612e504a37139cc3efe4a6a1537d349a9d2c62bef9c5f7542cb6f7359728747e90649145b71d14a494d
+EBUILD html401-19991224-r3.ebuild 770 BLAKE2B 179a7536508b34bbf0da36ad9f0257ada973087719fb0d99641180e41952f9fe61ce8ef5e88d1b3e796245f117766cd5291657d666cd9d20278e0209193a5c21 SHA512 dc50b833445d5901f5a18726cdebbd3c30584c738dbf6b5b00f45072b9dab856385ee9a6ab9ef0862818d132a3a0da17fedf4b4064e47d8e0f735868d0899471
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/html401/html401-19991224-r3.ebuild b/app-text/html401/html401-19991224-r3.ebuild
new file mode 100644
index 000000000000..c6742475dd1a
--- /dev/null
+++ b/app-text/html401/html401-19991224-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit sgml-catalog eutils
+
+DESCRIPTION="DTDs for the HyperText Markup Language 4.01"
+HOMEPAGE="http://www.w3.org/TR/html401/"
+SRC_URI="http://www.w3.org/TR/html401/html40.tgz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+DEPEND="app-text/sgml-common"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ sgml-catalog_cat_include "/etc/sgml/${PN}.cat" \
+ "/usr/share/sgml/${PN}/HTML4.cat"
+ epatch "${FILESDIR}"/${PN}-decl.diff
+}
+
+src_install() {
+ insinto /usr/share/sgml/${PN}
+ doins HTML4.cat HTML4.decl *.dtd *.ent
+ insinto /usr/share/doc/${PF}/html
+ doins -r *.html $(ls -p | fgrep "/" | sed "s#/##")
+}