summaryrefslogtreecommitdiff
path: root/app-text/gv/gv-3.7.3.90.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/gv/gv-3.7.3.90.ebuild')
-rw-r--r--app-text/gv/gv-3.7.3.90.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-text/gv/gv-3.7.3.90.ebuild b/app-text/gv/gv-3.7.3.90.ebuild
index 95b3ac253ccb..9ceecd9b1cb7 100644
--- a/app-text/gv/gv-3.7.3.90.ebuild
+++ b/app-text/gv/gv-3.7.3.90.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
+
+inherit desktop
DESCRIPTION="Viewer for PostScript and PDF documents using Ghostscript"
HOMEPAGE="https://www.gnu.org/software/gv/"
@@ -14,7 +15,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="xinerama"
-RDEPEND="app-text/ghostscript-gpl
+RDEPEND="
+ app-text/ghostscript-gpl
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
@@ -25,10 +27,8 @@ RDEPEND="app-text/ghostscript-gpl
x11-libs/libXt
xinerama? ( x11-libs/libXinerama )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto"
-
-DOCS="AUTHORS ChangeLog NEWS README"
+BDEPEND="virtual/pkgconfig"
src_configure() {
export ac_cv_lib_Xinerama_main=$(usex xinerama)
@@ -36,7 +36,9 @@ src_configure() {
}
src_install() {
+ rm README.{I18N,TRANSLATION} || die
default
+
doicon "${FILESDIR}"/gv_icon.xpm
make_desktop_entry gv GhostView gv_icon 'Graphics;Viewer'
}