summaryrefslogtreecommitdiff
path: root/app-text/grip/grip-4.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/grip/grip-4.5.2.ebuild')
-rw-r--r--app-text/grip/grip-4.5.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/grip/grip-4.5.2.ebuild b/app-text/grip/grip-4.5.2.ebuild
new file mode 100644
index 000000000000..ebeeb4c683ee
--- /dev/null
+++ b/app-text/grip/grip-4.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Preview GitHub Markdown files like Readme locally before committing them"
+HOMEPAGE="https://github.com/joeyespo/grip"
+LICENSE="MIT"
+
+SLOT="0"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/docopt-0.4.0
+ >=dev-python/flask-0.10.1
+ >=dev-python/markdown-2.5.1
+ >=dev-python/path-and-address-2.0.1
+ >=dev-python/pygments-1.6
+ >=dev-python/requests-2.4.1
+"