summaryrefslogtreecommitdiff
path: root/app-text/foliate/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/foliate/files')
-rw-r--r--app-text/foliate/files/foliate-validate.patch31
-rw-r--r--app-text/foliate/files/foliate-webkit.patch13
2 files changed, 0 insertions, 44 deletions
diff --git a/app-text/foliate/files/foliate-validate.patch b/app-text/foliate/files/foliate-validate.patch
deleted file mode 100644
index 45d2c42eef73..000000000000
--- a/app-text/foliate/files/foliate-validate.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -r -U3 foliate-2.6.4.orig/data/meson.build foliate-2.6.4/data/meson.build
---- foliate-2.6.4.orig/data/meson.build 2022-01-13 19:23:26.000000000 +0700
-+++ foliate-2.6.4/data/meson.build 2023-05-14 13:08:00.443754308 +0700
-@@ -7,13 +7,6 @@
- install_dir: join_paths(get_option('datadir'), 'applications')
- )
-
--desktop_utils = find_program('desktop-file-validate', required: false)
--if desktop_utils.found()
-- test('Validate desktop file', desktop_utils,
-- args: [desktop_file]
-- )
--endif
--
- appstream_file = i18n.merge_file(
- input: 'com.github.johnfactotum.Foliate.metainfo.xml.in',
- output: 'com.github.johnfactotum.Foliate.metainfo.xml',
-@@ -22,13 +15,6 @@
- install_dir: join_paths(get_option('datadir'), 'metainfo')
- )
-
--appstream_util = find_program('appstream-util', required: false)
--if appstream_util.found()
-- test('Validate appstream file', appstream_util,
-- args: ['validate', appstream_file]
-- )
--endif
--
- install_data('com.github.johnfactotum.Foliate.gschema.xml',
- install_dir: join_paths(get_option('datadir'), 'glib-2.0/schemas')
- )
diff --git a/app-text/foliate/files/foliate-webkit.patch b/app-text/foliate/files/foliate-webkit.patch
deleted file mode 100644
index cb559bf0003d..000000000000
--- a/app-text/foliate/files/foliate-webkit.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/main.js b/src/main.js
-index 718d420..2ea2018 100644
---- a/src/main.js
-+++ b/src/main.js
-@@ -18,7 +18,7 @@ pkg.initFormat()
- pkg.require({
- 'Gio': '2.0',
- 'Gtk': '3.0',
-- 'WebKit2': '4.0'
-+ 'WebKit2': '4.1'
- })
-
- const { Gio, Gtk, Gdk, GLib, WebKit2 } = imports.gi