summaryrefslogtreecommitdiff
path: root/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild')
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild
deleted file mode 100644
index 02055e6d7f0d..000000000000
--- a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="EditorConfig core library written in C"
-HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
-SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE="cli doc"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-DEPEND="dev-libs/libpcre2:="
-RDEPEND="${DEPEND}
- cli? ( !dev-python/editorconfig-core-py[cli] )"
-
-PATCHES=( "${FILESDIR}/${P}-no-static-libs.patch" )
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
- )
- cmake_src_configure
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake_src_install
-
- if ! use cli; then
- rm -r "${ED}/usr/bin" || die
- fi
-}