summaryrefslogtreecommitdiff
path: root/app-text/dvibook
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dvibook')
-rw-r--r--app-text/dvibook/Manifest6
-rw-r--r--app-text/dvibook/dvibook-20001129.ebuild37
-rw-r--r--app-text/dvibook/files/dvibook-20001129.patch253
-rw-r--r--app-text/dvibook/metadata.xml8
4 files changed, 304 insertions, 0 deletions
diff --git a/app-text/dvibook/Manifest b/app-text/dvibook/Manifest
new file mode 100644
index 000000000000..dbace97ae503
--- /dev/null
+++ b/app-text/dvibook/Manifest
@@ -0,0 +1,6 @@
+AUX dvibook-20001129.patch 6625 SHA256 f406a7c7200d6b2ecbdb37065ef4b89d71107c6c7f35e5080aacb6c7488d2a31 SHA512 9e5ee7d42da5c77061ea0c59d4784cf1c0e197c03d37586cf9f2d13bd4c740149b9100609a98c1f7aa4a71b80cc4f7328c65cc40b3c476bcb0d672da091cc8cc WHIRLPOOL 042854068dbbd45f6c883f93f0c164ff9012cb7149cd810e6e5b3ef9c71ad59c3504529e325e3ab6ae08e70c9953942ade90f0a02872f9a25a7c204f5ed076ce
+DIST dvibook-20001129.tar.gz 141312 SHA256 d0217d94ecc8c15f4d5aafe94d63e26de5957882a14ea4bdd95f518bd31f125d SHA512 7d9991d8d870951f3e68a5b931ea05466b85dd5b23c5f62ebe3e4c2ddc0650677a0e65f506b7b66938f297a95200879cdbe3370e3e3a92b68bab1b671923d590 WHIRLPOOL fb5251b7f072d26201099674fb5509288bbec6629646810551ea1b1a56665a530ba1779edd56e16e19021d1843664c4e16be27a7bb79189f7d906f27e84b1439
+EBUILD dvibook-20001129.ebuild 731 SHA256 689b2c2cb783cff1507ef35b6ae09614728d95a3d6efcc96502dff7900894ebf SHA512 0eb857c5ea94cb491a785de3b5a6baa34ddde24f342cc452d0280e88785b3427ab097803b88b3f92667fd805725ed8987815eaee2163dfde1d914144c56839a5 WHIRLPOOL b12c76053ab7fc1d548a474bc7d7c2f0c5fc9ac52576c46aadc752faee3fafe2f9896bb88961f464faa723b358053dfb6052a290990f3da373949ac8fc0f8855
+MISC ChangeLog 2464 SHA256 f0c12b91cdfaa326266ca44a8daf8bb55e1d6076cf364cf4a053e8b1fa3dd8cb SHA512 8fdf22d0207dbc2295351de7349e56e2b404e380cd6c8010e691f84b6aacda2de74fb77f34f7cada7cc1c75bb4271d8f7ca6fcca88130abd1c79fe95ebfe2638 WHIRLPOOL 152ae8154a3db4c96fa500776d5e3b824e6d81a1af47749dde68f4ccae852622c62b4bf6fb71d89748297d8a66df2ea288b60faa664e8dfdacc249d2c05b4d26
+MISC ChangeLog-2015 1517 SHA256 88634770a01781228b5ca46c5d1d22b9b5ba63604f09243e7833d5617acc8a42 SHA512 41600f4a90664cfdcd4682185a52e30b4679a77258da042421e47671fab216d876de9184e79c7b113effe7bbfb212fbac454d1d324fb63314b4f3a3313600254 WHIRLPOOL 938edc597db944614102f0d6a7708e1f2e88068ee75ae312fb819004009d0f8c470a42fb5aa5389551586100fa29b1c6c7b0fd526bd529addcb76edb5101afb2
+MISC metadata.xml 245 SHA256 b3de478821488be2cdc91b078e21c911dc384af882c5c44631a47dfa91516dc8 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690 WHIRLPOOL 701a78fc2214f5fd4bd781477f85e87e716b8d76ea831a0fa4afc8871c4286cc363679f1ff4f844555ad4f77cc7265208b83e805f56c22fc4baeed1062280c08
diff --git a/app-text/dvibook/dvibook-20001129.ebuild b/app-text/dvibook/dvibook-20001129.ebuild
new file mode 100644
index 000000000000..bfe0374149f5
--- /dev/null
+++ b/app-text/dvibook/dvibook-20001129.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="DVI file utilities: dvibook, dviconcat, dvitodvi, and dviselect"
+HOMEPAGE="http://www.ctan.org/tex-archive/dviware/dvibook/"
+# Taken from: ftp://tug.ctan.org/tex-archive/dviware/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="dvibook"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="x11-misc/imake
+ x11-misc/gccmakedep
+ app-text/rman"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}.patch"
+)
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+ dodoc README
+}
diff --git a/app-text/dvibook/files/dvibook-20001129.patch b/app-text/dvibook/files/dvibook-20001129.patch
new file mode 100644
index 000000000000..595ac98ecac5
--- /dev/null
+++ b/app-text/dvibook/files/dvibook-20001129.patch
@@ -0,0 +1,253 @@
+diff -Nur dvibook-orig/Dvibook/Imakefile dvibook/Dvibook/Imakefile
+--- dvibook-orig/Dvibook/Imakefile 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Dvibook/Imakefile 2004-07-08 09:24:05.038918792 +0200
+@@ -1,24 +1,15 @@
+-OBJS =dvibook.o
+-SRCS =dvibook.c
++#include "../Imake.Config"
+
+- LIBTEXROOT= ../
+- LIBTEXSRC = ../libtex
+- LIBTEX = $(LIBTEXSRC)/libtex.a
+- DEPLIBTEX = $(LIBTEX)
+- DEPLIBS = $(DEPLIBTEX) XawClientDepLibs
+-LOCAL_LIBRARIES = $(LIBTEX)
+-
+- DEFINES = -I$(LIBTEXROOT)
++ BINDIR = $(TEX_BINDIR)
++ MANDIR = $(TEX_MANDIR)
+
+-FILES =Imakefile dvibook.man Makefile.raw $(SRCS)
++ FILES = Imakefile dvibook.man $(SRCS)
+
+-all: dvibook
++ INCLUDES = -I$(LIBTEXROOT)
++LOCAL_LIBRARIES = $(LIBTEX)
++ DEPLIBS = $(DEPLIBTEX)
+
+-NormalProgramTarget(dvibook,$(OBJS),$(DEPLIBS),$(LOCAL_LIBRARIES),$(SYSLIBS))
+-InstallProgram(dvibook, $(BINDIR))
+-InstallManPage(dvibook,$(MANDIR))
+-DependTarget()
+-TagsTarget()
++SimpleProgramTarget(dvibook)
+
+ tar:
+ cd ../..;\
+diff -Nur dvibook-orig/Dvitodvi/Imakefile dvibook/Dvitodvi/Imakefile
+--- dvibook-orig/Dvitodvi/Imakefile 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Dvitodvi/Imakefile 2004-07-08 09:24:05.039918647 +0200
+@@ -1,24 +1,15 @@
+-OBJS =dvitodvi.o
+-SRCS =dvitodvi.c
++#include "../Imake.Config"
+
+- LIBTEXROOT= ../
+- LIBTEXSRC = ../libtex
+- LIBTEX = $(LIBTEXSRC)/libtex.a
+- DEPLIBTEX = $(LIBTEX)
+- DEPLIBS = $(DEPLIBTEX) XawClientDepLibs
+-LOCAL_LIBRARIES = $(LIBTEX)
+-
+- DEFINES = -I$(LIBTEXROOT)
++ BINDIR = $(TEX_BINDIR)
++ MANDIR = $(TEX_MANDIR)
+
+-FILES =Imakefile dvitodvi.man Makefile.raw $(SRCS)
++ FILES = Imakefile dvitodvi.man $(SRCS)
+
+-all: dvitodvi
++ INCLUDES = -I$(LIBTEXROOT)
++LOCAL_LIBRARIES = $(LIBTEX)
++ DEPLIBS = $(DEPLIBTEX)
+
+-NormalProgramTarget(dvitodvi,$(OBJS),$(DEPLIBS),$(LOCAL_LIBRARIES),$(SYSLIBS))
+-InstallProgram(dvitodvi, $(BINDIR))
+-InstallManPage(dvitodvi,$(MANDIR))
+-DependTarget()
+-TagsTarget()
++SimpleProgramTarget(dvitodvi)
+
+ tar:
+ cd ../..;\
+diff -Nur dvibook-orig/Imake.Config dvibook/Imake.Config
+--- dvibook-orig/Imake.Config 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/Imake.Config 2004-07-08 09:24:05.039918647 +0200
+@@ -1,8 +1,8 @@
+ /* * Install directories for programs not related to X */
+
+-TEX_BINDIR = /srl/TeX/bin
+-TEX_MANDIR = /srl/TeX/man/man1
+-TEX_INPUTS = /srl/TeX/lib/tex/inputs
++TEX_BINDIR = /usr/bin
++TEX_MANDIR = /usr/share/man/man1
++MANSUFFIX = 1
+
+ /*
+ * Set `FONTDESC' to the location of your fontdesc file, unquoted.
+@@ -189,7 +189,7 @@
+ /*
+ * Undefine GETOP if your loader complains about multiple ref's.
+ */
+-#if 1
++#if 0
+ GETOPT=getopt.o
+ #else
+ GETOPT=
+diff -Nur dvibook-orig/libtex/error.c dvibook/libtex/error.c
+--- dvibook-orig/libtex/error.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/error.c 2004-07-08 09:24:05.054916460 +0200
+@@ -21,7 +21,7 @@
+ #include "types.h" /* for HAVE_VPRINTF */
+ #include "error.h"
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+
+ #if defined(lint) && !defined(LINT_ANYWAY)
+
+@@ -34,12 +34,9 @@
+ /* VARARGS1 ARGSUSED */
+ void panic(fmt) char *fmt; { exit(1); /* NOTREACHED */ }
+
+-#else lint
++#else /* lint */
+
+ extern char *ProgName; /* program name from argv[0] */
+-extern int errno; /* Unix system-call error */
+-extern char *sys_errlist[]; /* table of error number => string */
+-extern int sys_nerr; /* size of table */
+
+ static FILE *trap_file; /* error diversion file, if any */
+ static void (*trap_fn)(); /* trap function */
+@@ -143,10 +140,7 @@
+ (void) _doprnt(fmt, l, fp);
+ #endif
+ if (e) {
+- if (e < sys_nerr)
+- (void) fprintf(fp, ": %s", sys_errlist[e]);
+- else
+- (void) fprintf(fp, ": Unknown error code %d", e);
++ (void) fprintf(fp, ": %s", strerror(e));
+ }
+ (void) putc('\n', fp);
+ (void) fflush(fp);
+@@ -160,18 +154,11 @@
+ * Print an error message and optionally quit.
+ */
+ void
+-error(va_alist)
+- va_dcl
++error(int quit, int e, const char *fmt, ...)
+ {
+ va_list l;
+- int quit, e;
+- char *fmt;
+
+- va_start(l);
+- quit = va_arg(l, int);
+- if ((e = va_arg(l, int)) < 0)
+- e = errno;
+- fmt = va_arg(l, char *);
++ va_start(l, fmt);
+ verror(quit, (char *)NULL, fmt, l, e);
+ va_end(l);
+ }
+@@ -180,15 +167,12 @@
+ * Panic (print to stderr and abort).
+ */
+ void
+-panic(va_alist)
+- va_dcl
++panic(const char *fmt, ...)
+ {
+ va_list l;
+- char *fmt;
+
+ SetErrorTrap((void (*)())NULL); /* shut down any trap */
+- va_start(l);
+- fmt = va_arg(l, char *);
++ va_start(l, fmt);
+ verror(0, "panic: ", fmt, l, 0);
+ va_end(l);
+ abort();
+diff -Nur dvibook-orig/libtex/error.h dvibook/libtex/error.h
+--- dvibook-orig/libtex/error.h 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/error.h 2004-07-08 09:24:05.054916460 +0200
+@@ -8,7 +8,7 @@
+ /*
+ * Errors.
+ */
+-void error(/* int quit, int e, char *fmt, ... */);
+-void panic(/* char *fmt, ... */);
++void error(int quit, int e, const char *fmt, ...);
++void panic(const char *fmt, ...);
+
+ void SetErrorTrap(/* void (*fn)(int quit, char *text) */);
+diff -Nur dvibook-orig/libtex/gripes0.c dvibook/libtex/gripes0.c
+--- dvibook-orig/libtex/gripes0.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/gripes0.c 2004-07-08 09:24:05.054916460 +0200
+@@ -14,12 +14,11 @@
+ */
+
+ #include <stdio.h>
++#include <errno.h>
+ #include "types.h"
+ #include "error.h"
+ #include "gripes.h"
+
+-extern errno;
+-
+ /*
+ * Cannot allocate memory.
+ */
+diff -Nur dvibook-orig/libtex/sdecode.c dvibook/libtex/sdecode.c
+--- dvibook-orig/libtex/sdecode.c 1994-03-19 01:00:00.000000000 +0100
++++ dvibook/libtex/sdecode.c 2004-07-08 09:24:05.055916315 +0200
+@@ -10,7 +10,7 @@
+ #endif
+
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "types.h"
+ #include "sdecode.h"
+
+@@ -21,7 +21,7 @@
+ static int sdset; /* flag says whether cclass[] set up */
+
+ static void args(), badarg();
+-static int scan(), scan_i(), scan_d();
++static int scan_i(), scan_d();
+
+ extern char *strsave();
+
+@@ -80,6 +80,8 @@
+ int di_bkw; /* true iff keyword is in static buffer */
+ };
+
++static int scan(register struct decode_info *di, ...);
++
+ /*
+ * `Edit' the text in the buffer in-place.
+ * Return the count of characters resulting from the edit (e.g.,
+@@ -553,17 +555,14 @@
+ }
+
+ static int
+-scan(va_alist)
+- va_dcl
++scan(register struct decode_info *di, ...)
+ {
+- register struct decode_info *di;
+ register char *fmt;
+ register int c;
+ char **fmtp;
+ va_list ap;
+
+- va_start(ap);
+- di = va_arg(ap, struct decode_info *);
++ va_start(ap, di);
+ fmtp = va_arg(ap, char **);
+ fmt = *fmtp;
+ while ((c = *fmt++) != 0) {
diff --git a/app-text/dvibook/metadata.xml b/app-text/dvibook/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/app-text/dvibook/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>