summaryrefslogtreecommitdiff
path: root/app-text/cmark/cmark-0.28.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/cmark/cmark-0.28.0.ebuild')
-rw-r--r--app-text/cmark/cmark-0.28.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/cmark/cmark-0.28.0.ebuild b/app-text/cmark/cmark-0.28.0.ebuild
new file mode 100644
index 000000000000..8645624e81eb
--- /dev/null
+++ b/app-text/cmark/cmark-0.28.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}