summaryrefslogtreecommitdiff
path: root/app-text/blahtexml
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/blahtexml')
-rw-r--r--app-text/blahtexml/Manifest6
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild39
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-Makefile.patch55
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch24
-rw-r--r--app-text/blahtexml/files/blahtexml.190
-rw-r--r--app-text/blahtexml/metadata.xml5
6 files changed, 219 insertions, 0 deletions
diff --git a/app-text/blahtexml/Manifest b/app-text/blahtexml/Manifest
new file mode 100644
index 000000000000..672333f71600
--- /dev/null
+++ b/app-text/blahtexml/Manifest
@@ -0,0 +1,6 @@
+AUX blahtexml-0.9-Makefile.patch 1811 BLAKE2B c84ab5b3781413ff04e771849514ec244354a39c65d3568d698f48bd1b77d13374664e72007d0a8ab9cf69c10398d01f7d8c3cf63a7759a4bc66b566836deab1 SHA512 e27fc386b4392d33fe6b78379d364d3b17586c12843acf18fa16244169d151f8e750804289114c24f179fca6b0abe94f4eb622089af90c538dd7e9f3182d8d18
+AUX blahtexml-0.9-gcc-4.7.patch 672 BLAKE2B 37e3ed661675e36d833f9dcdc535de3ba62ba57fa283f39af7981659d8739798a6d76adf831c042f24813cdcb0f1495f978e5fd822b11a1064cb22e3d7b0cbb4 SHA512 d683ea1113f4aaefb692b8a7b0cb7365673c835fa3c85e229243d0c96ee2b2ff52026dec96d1670cc0e42f1fa9124dfd547445e6e5b0a85f462e881f177d2ad4
+AUX blahtexml.1 3094 BLAKE2B a1b1bd3d1a6952529685b8be5c22f12a1d6168b7d37eea958fd295a593e17ff363c966e46bf26f8f28a2f424a34344c7673e96d976088b9726dfd1717042edb3 SHA512 0f114e4cfb806fe6d120a738118ccd0817d898434a9d878cd20e5ea59d804420f07b90b9763a387e5b29251ca4acf9b1d7b7b845f9f86036d9dc729775155a7d
+DIST blahtexml-0.9-src.tar.gz 168564 BLAKE2B 941f241adf6e423cd0eff4a13b11313d6cad143badb6d862be01bd603f84aa04f224ae2d84abfef05341c66e410ba18bf39d99f636a8a33512e1da9739770a19 SHA512 5a5ddd50c0b3a25954135c44de0ac3a3d992e3e9dd691a552512415c385a39011595683877cdf98aee77d6ef2f9dae750214798ec2af69b8de089d0aec64b042
+EBUILD blahtexml-0.9.ebuild 793 BLAKE2B 1a17181c2e5dc6c8f73e09fbe7b4d4a8b5d7b461965cd73a1406d5d93cbbd7a17b2b0a4cbbb34b1ed9dce4f5ad5d5dc9dfa563f7c289fa4ecf8bdffea2a94bd5 SHA512 a3077051e5cf0638189d51a1bc43711fd7433d17311383f4fbd5d2805a9cb975becaf2e3855d119e588d3fda0a72f49a47f322dbeb3e084cc5c533a0127dea7b
+MISC metadata.xml 168 BLAKE2B 5f277cc66dbafa7e7985433f84b0f9a656a176a9b901862e2a8353ca2d4526797dded9696e835b9696c7f72324e94959cfb5a22de49a7e3e61604153886037ab SHA512 00eec08786156434460f5ed77b647579546cf1a86341a4f2c9c9c84326468c2c21dc5101c4277103b19266bb6f788823f4ddf3b9d044da26326d79bf2ac9a274
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
new file mode 100644
index 000000000000..ee195e68bed9
--- /dev/null
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TeX-to-MathML converter"
+HOMEPAGE="http://gva.noekeon.org/blahtexml"
+SRC_URI="http://gva.noekeon.org/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD CC-BY-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/xerces-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/texlive-core
+ dev-libs/libxslt
+ dev-tex/latex2html )"
+
+src_prepare() {
+ tc-export CC CXX
+ epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+}
+
+src_compile() {
+ emake blahtex{,ml}-linux
+ use doc && emake doc
+}
+
+src_install() {
+ dobin blahtex ${PN}
+ doman "${FILESDIR}"/${PN}.1
+ use doc && dodoc Documentation/manual.pdf
+}
diff --git a/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
new file mode 100644
index 000000000000..f5f01eac71aa
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
@@ -0,0 +1,55 @@
+Use pkg-config for xerces-c
+Respect CXX and CC
+Replace CFLAGS with CXXFLAGS where needed
+Add LDFLAGS
+
+--- a/makefile
++++ b/makefile
+@@ -93,35 +93,40 @@
+
+ $(BINDIR_XMLIN)/InputSymbolTranslation.o: InputSymbolTranslation.cpp InputSymbolTranslation.inc
+
+-CFLAGS = -O2
++PKG_CONFIG ?= pkg-config
++CFLAGS ?= -O2
+
+ VPATH = Source:Source/BlahtexCore:Source/BlahtexXMLin
+
+ INCLUDES=-I. -ISource -ISource/BlahtexCore -ISource/BlahtexXMLin
+
++CXXFLAGS += $(shell $(PKG_CONFIG) --cflags xerces-c)
++
++XERCES_LIB = $(shell $(PKG_CONFIG) --libs xerces-c)
++
+ $(BINDIR)/%.o:%.cpp
+- $(CXX) $(INCLUDES) $(CFLAGS) -c $< -o $@
++ $(CXX) $(INCLUDES) $(CXXFLAGS) -c $< -o $@
+
+ $(BINDIR)/%.o:%.c
+ $(CC) $(INCLUDES) $(CFLAGS) -c $< -o $@
+
+ $(BINDIR_XMLIN)/%.o:%.cpp
+- $(CXX) $(INCLUDES) $(CFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
++ $(CXX) $(INCLUDES) $(CXXFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
+
+ $(BINDIR_XMLIN)/%.o:%.c
+ $(CC) $(INCLUDES) $(CFLAGS) -DBLAHTEXML_USING_XERCES -c $< -o $@
+
+ blahtex-linux: $(BINDIR) $(OBJECTS) $(HEADERS)
+- $(CXX) $(CFLAGS) -o blahtex $(OBJECTS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtex $(OBJECTS) $(LIBS)
+
+ blahtex-mac: $(BINDIR) $(OBJECTS) $(HEADERS)
+- $(CXX) $(CFLAGS) -o blahtex -liconv $(OBJECTS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtex -liconv $(OBJECTS) $(LIBS)
+
+ blahtexml-linux: $(BINDIR_XMLIN) $(OBJECTS_XMLIN) $(HEADERS_XMLIN)
+- $(CXX) $(CFLAGS) -o blahtexml $(OBJECTS_XMLIN) -lxerces-c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtexml $(OBJECTS_XMLIN) $(LIBS) $(XERCES_LIB)
+
+ blahtexml-mac: $(BINDIR_XMLIN) $(OBJECTS_XMLIN) $(HEADERS_XMLIN)
+- $(CXX) $(CFLAGS) -o blahtexml -liconv $(OBJECTS_XMLIN) -lxerces-c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o blahtexml -liconv $(OBJECTS_XMLIN) $(LIBS) $(XERCES_LIB)
+
+ clean:
+ rm -f blahtex $(OBJECTS) blahtexml $(OBJECTS_XMLIN)
diff --git a/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
new file mode 100644
index 000000000000..c570e1de679b
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
@@ -0,0 +1,24 @@
+Description: Fix FTBFS with gcc 4.7 by fixing missing <unistd.h> includes.
+Author: Cyril Brulebois <kibi@debian.org>
+Bug-Debian: http://bugs.debian.org/667116
+
+--- blahtexml-0.9.orig/Source/main.cpp
++++ blahtexml-0.9/Source/main.cpp
+@@ -24,6 +24,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
+ #include <stdlib.h>
+ #include <sstream>
+ #include <stdexcept>
++#include <unistd.h>
+
+ using namespace std;
+ using namespace blahtex;
+--- blahtexml-0.9.orig/Source/mainPng.cpp
++++ blahtexml-0.9/Source/mainPng.cpp
+@@ -27,6 +27,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sstream>
++#include <unistd.h>
+
+
+ using namespace std;
diff --git a/app-text/blahtexml/files/blahtexml.1 b/app-text/blahtexml/files/blahtexml.1
new file mode 100644
index 000000000000..a82c8491a770
--- /dev/null
+++ b/app-text/blahtexml/files/blahtexml.1
@@ -0,0 +1,90 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH BLAHTEXML 1 "March 17, 2010"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+blahtexml \- Converts TeX equations into MathML
+.SH SYNOPSIS
+.B blahtexml
+.RI [ options ] " files" ...
+.SH DESCRIPTION
+This manual page documents briefly the
+.B blahtexml
+command.
+.PP
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+\fBblahtexml\fP converts an equation given in a syntax close to TeX into
+MathML. Blahtexml is a simple extension of blahtex. In addition to
+the functionality of blahtex, blahtexml has XML processing in mind
+and is able to process a whole XML document into another XML
+document. Instead of converting only one formula at a time, blahtexml
+can convert all the formulas of the given XML file into MathML.
+.SH OPTIONS
+These programs follow the usual GNU command line syntax, with long
+options starting with two dashes (`-').
+A summary of options is included below.
+For a complete description, see the online documentation.
+.TP
+.B \-\-help
+Show summary of options.
+.TP
+.B \-\-texvc-compatible-commands
+Enables use of commands that are specific to texvc, but that are not
+standard TeX/LaTeX/AMS-LaTeX commands.
+.TP
+.B \-\-print-error-messages
+This will print out a list of all error IDs and corresponding messages
+that blahtex can possibly emit inside an <error> block.
+.SH MATHML OPTIONS
+These options control the MathML output of the blahtexml program.
+
+.TP
+.B \-\-mathml
+Enables MathML output.
+.TP
+.B \-\-xmlin
+This allows one to embed TeX equations in an existing MathML code, using
+a special notation. The equations are given as attributes (inline or block)
+in the http://gva.noekeon.org/blahtexml namespace. Whenever blahtexml meets
+such an equation, it expands it into the equivalent MathML code.
+
+For more information check
+.RS
+http://gva.noekeon.org/blahtexml/how_to_use.html
+.RE
+.RS
+or the blahtexml manual.
+.RE
+.TP
+.B \-\-annotate-TeX
+Produces TeX annotations in the MathML output.
+.TP
+.B \-\-annotate-PNG
+Produces PNG files and annotates the MathML output with the PNG file name.
+.SH SEE ALSO
+The program is documented fully by the
+online manual available at:
+http://gva.noekeon.org/blahtexml
+.SH AUTHOR
+blahtexml was written by Gilles Van Assche.
+.br
+blahtex (whose superset is blahtexml) was written by David Harvey.
+.PP
+This manual page was written by Abhishek Dasgupta <abhidg@gmail.com>,
+for the Debian project (but may be used by others).
+
diff --git a/app-text/blahtexml/metadata.xml b/app-text/blahtexml/metadata.xml
new file mode 100644
index 000000000000..1b2becffa26c
--- /dev/null
+++ b/app-text/blahtexml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>