summaryrefslogtreecommitdiff
path: root/app-text/barcode/barcode-0.99.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/barcode/barcode-0.99.ebuild')
-rw-r--r--app-text/barcode/barcode-0.99.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/barcode/barcode-0.99.ebuild b/app-text/barcode/barcode-0.99.ebuild
new file mode 100644
index 000000000000..5b04b0aef75b
--- /dev/null
+++ b/app-text/barcode/barcode-0.99.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib
+
+DESCRIPTION="barcode generator"
+HOMEPAGE="https://www.gnu.org/software/barcode/"
+SRC_URI="mirror://gnu/barcode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+RDEPEND="app-text/libpaper"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e '/^LDFLAGS =/s:=:+=:' \
+ -e "/^aLIBDIR/s:lib:$(get_libdir):" \
+ -e '/^INFODIR/s:info:share/info:' \
+ -e '/^MAN/s:man:share/man:' \
+ Makefile.in || die
+
+ default
+}
+
+src_install() {
+ default
+ dodoc ChangeLog README TODO
+}