summaryrefslogtreecommitdiff
path: root/app-text/asciidoc
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/Manifest4
-rw-r--r--app-text/asciidoc/asciidoc-10.2.1.ebuild64
-rw-r--r--app-text/asciidoc/asciidoc-9.1.0.ebuild84
3 files changed, 66 insertions, 86 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index bafbebc235ed..8b1d42d0a600 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1,5 +1,5 @@
DIST asciidoc-10.2.0.tar.gz 216824 BLAKE2B 500038d655f820fe89048bbff683ae029c7044de839ae4f9ec4666b843585511c99bbc1991ec1764262f33c55b08845661fc1e62eb21bb3250d3168e369928ff SHA512 2f83c7f6d1d0a34948035347833ca59841de1271e8d008b4c4a43a7a8273b230148e6f51ee8f6e2dc702460e27c495037fbe2d6d43195b70bf3447ad86390d28
-DIST asciidoc-9.1.0.new.tar.gz 1249958 BLAKE2B 0a98f58f7604f84d704092313c38563634bad5d697d60d02760f3be1d2a78a97ee2488dda3a9918b02e0062710175c6513d600f3fbd850fe700bf3fa917a3980 SHA512 c30854a936228fe5bcf2f9305741fbc4b17ef088b2fa637d5f3b19c7803306085634fb71146f0b089c2fad01f986da71a4fae364139f520c0906525317c0c4a6
+DIST asciidoc-10.2.1.tar.gz 1280535 BLAKE2B 9e15eb5d40384fe586a6148e53e03e73a6958061841843f7b32b4209a15477f97a6547ea1cb48d23b5d4c9ee5add1bfa87d53c1bfbc14c10f31397ebeb86ba39 SHA512 02d064aab8dfb05af4ae49a7c7bd1381156c6c90f95b2494218c80f01c39987cb971d68c533b5519abade77be9832b3fab653d8ae2ca7bb682c5bb720612839f
EBUILD asciidoc-10.2.0.ebuild 1448 BLAKE2B d21ab08ffd08ee3799ce73955cd4d5cf3d5340d733a48abf7d7793631bb15cdb7bf2759f42ade59cdd777abb090edc1b2ee9416d580b8efa4f2afb339a40a20f SHA512 329740f7a68ae62d113f51a139d13f324521fa2f436bb6c1ca89ec5be757476bf334a1537d9d797b9156ad03d6ffa21f1514a019c953058efbf1913cf3d2416c
-EBUILD asciidoc-9.1.0.ebuild 2289 BLAKE2B e1412278721c83616614cad672cfd9acf716b1dc536bda8882be0d12322a8e2d48dabc3f539616715879a8a620a8f1f4e31d44d32641cd4bc219fe1a53c27948 SHA512 01033329b222c38addb0789422605af900769fe4d1fe7da6f01210234f66c8f460b22d701cbc5a6662c30f5e276ea41748f06d79807382e1d602db65b578e001
+EBUILD asciidoc-10.2.1.ebuild 1714 BLAKE2B 2edc0f11f57e2de78ad2d236c4e185012ca033fd6ae9d211afe6f785123e829377f93753cc2d5e0e1c13c09b1bb59f70f4977c910411de9199c82388276ac0a3 SHA512 fedfd47cad249e3ce4963b2ad497f631ed5e09f7d754284eaf2d4d38f1c333abcca347d594647c820512e7bba0c3e8cf38822fb6465dbc6b4538d75678e7dcc1
MISC metadata.xml 437 BLAKE2B daddb5640390428ca681f4efacc9fb3e02d11687644d2ff2d233fc5fa59f7950dbe8cef9f875f3e2af077a74567a4e4f48b187b1eab64e5a9d4ef3f5b1cffa1b SHA512 5d281a8e6fd3dd551a9d5df099f3b0586c363f4295a5e9bdb63c82a501d076e04c3b4a88f0f861d445ef3bb22970b10e15eb98094375f3e634cbbe506432bedd
diff --git a/app-text/asciidoc/asciidoc-10.2.1.ebuild b/app-text/asciidoc/asciidoc-10.2.1.ebuild
new file mode 100644
index 000000000000..af922182340a
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-10.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+inherit distutils-r1 optfeature readme.gentoo-r1
+
+DESCRIPTION="A plain text human readable/writable document format"
+HOMEPAGE="
+ https://asciidoc.org/
+ https://github.com/asciidoc-py/asciidoc-py/
+"
+SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ dev-libs/libxml2:2
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep '
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ ') )
+"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ # TODO: Consider using Debian patch to allow /usr/share?
+ insinto /usr/share/asciidoc
+ doins -r asciidoc/resources/.
+
+ doman doc/*.1 # bug 834835
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "music filter support" \
+ "media-sound/lilypond virtual/imagemagick-tools"
+ optfeature "source filter support" \
+ "dev-util/source-highlight dev-python/pygments app-text/highlight"
+ optfeature "latex filter support" \
+ "dev-texlive/texlive-latex app-text/dvipng" \
+ "dev-texlive/texlive-latex app-text/dvisvgm"
+ optfeature "graphviz filter support" "media-gfx/graphviz"
+}
diff --git a/app-text/asciidoc/asciidoc-9.1.0.ebuild b/app-text/asciidoc/asciidoc-9.1.0.ebuild
deleted file mode 100644
index 075821590784..000000000000
--- a/app-text/asciidoc/asciidoc-9.1.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-inherit autotools optfeature python-single-r1 readme.gentoo-r1
-
-DESCRIPTION="A plain text human readable/writable document format"
-HOMEPAGE="https://asciidoc.org/ https://github.com/asciidoc-py/asciidoc-py/"
-SRC_URI="https://github.com/asciidoc-py/asciidoc-py/releases/download/${PV}/${P}.tar.gz -> ${P}.new.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- app-text/docbook-xml-dtd:4.5
- >=app-text/docbook-xsl-stylesheets-1.75
- dev-libs/libxslt
- dev-libs/libxml2:2
- "
-DEPEND="
- test? (
- ${PYTHON_DEPS}
- app-text/dvipng
- app-text/dvisvgm
- dev-texlive/texlive-latex
- dev-util/source-highlight
- media-gfx/graphviz
- media-gfx/imagemagick[png]
- media-sound/lilypond
- )"
-
-DOC_CONTENTS="
-If you are going to use a2x, please also look at a2x(1) under
-REQUISITES for a list of runtime dependencies.
-"
-
-DOCS=( BUGS.txt CHANGELOG.txt README.asciidoc
- docbook-xsl/asciidoc-docbook-xsl.txt dblatex/dblatex-readme.txt
- filters/code/code-filter-readme.txt )
-
-src_prepare() {
- default
- # Only needed for prefix - harmless (does nothing) otherwise
- sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
- asciidoc.py || die
-
- # enforce usage of the configured version of Python
- sed -i -e "s:python3:${EPYTHON}:" Makefile.in || die
-
- eautoreconf
-}
-
-src_configure() {
- econf --sysconfdir="${EPREFIX}"/usr/share
-}
-
-src_install() {
- default
-
- if use doc; then
- emake DESTDIR="${D}" docs
- fi
-
- python_fix_shebang "${ED}"/usr/bin/*.py
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-
- optfeature "\"music\" filter support" "media-sound/lilypond media-gfx/imagemagick"
- optfeature "\"source\" filter support" dev-util/source-highlight dev-python/pygments app-text/highlight
- optfeature "\"latex\" filter support" "dev-texlive/texlive-latex app-text/dvipng" "dev-texlive/texlive-latex app-text/dvisvgm"
- optfeature "\"graphviz\" filter support" media-gfx/graphviz
-}