summaryrefslogtreecommitdiff
path: root/app-text/an
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/an')
-rw-r--r--app-text/an/Manifest4
-rw-r--r--app-text/an/an-1.2-r1.ebuild39
-rw-r--r--app-text/an/an-1.2.ebuild40
-rw-r--r--app-text/an/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/app-text/an/Manifest b/app-text/an/Manifest
new file mode 100644
index 000000000000..bd3d024ceea1
--- /dev/null
+++ b/app-text/an/Manifest
@@ -0,0 +1,4 @@
+DIST an_1.2.orig.tar.xz 13196 BLAKE2B bbb19eb16e558f8fc3d331e5ad308611b13a7a88a65fb310b678bd21d46c39761747fb6f60a7eba99a1c2e756a8c9467543d26e97bbf7f9c93d17f66a4d7698c SHA512 919c525aa1215e3c1b2200c6820a357c6406c19b7447147cc4243d339c554b9892bea11797769df0bf96dd72c89f61bf3d977769faf9bc7f9edf609a7daeac3d
+EBUILD an-1.2-r1.ebuild 770 BLAKE2B f6ac00e6faf8e128ed85f7256fba39e6582cb976640cdc460ed4dee8fb0038b543a3d29e48d6c926cb6c85136626c0adf19970bdef3b642e4c67b88f75462df5 SHA512 618ae33718d53a0702798933fe3ee2c14856f76aee53682ea60c2baddc7c28f4800753cdc1f61a21cc9097824716d1d2237291d306d6642fbdabd4755299b226
+EBUILD an-1.2.ebuild 719 BLAKE2B 89ea6d80bdb55f99dab24ed234bc86ada3ab44202285b5d382c737bc42db8529ee19da1fb5c4f4aa120b95d0829f7bf5d384a5ecb21ff2600d19a358c11c75be SHA512 774b56f85bc3d9812e5824551f83aebca3d08e34e0857030cca8b378f57ab5032d6a6f5f1f0bc6b766df0c2b825b0cf91e30d259e4f6fb772ad374cc4b447d1b
+MISC metadata.xml 242 BLAKE2B 719b2221a59fb1ea608b2bab1d89d6694220253a34d1919062de0fd77c3148919ec1ee77a86e3a8699eb8034bec2ca03602fdbcc176784bd7d53e78cd29200e2 SHA512 01fa45ae0901d0f1bbae0a22f72b4c999c24b4718a0a1f7cf8db80ebb29c9a97903246e560ec7e5d5e6800f425b7e32172802206109e67545aa82b2fbac13cf9
diff --git a/app-text/an/an-1.2-r1.ebuild b/app-text/an/an-1.2-r1.ebuild
new file mode 100644
index 000000000000..d9c01423a53c
--- /dev/null
+++ b/app-text/an/an-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/unstable/games/an"
+
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/miscfiles[-minimal]
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ -e 's|$(CC) $(CFLAGS)|& $(LDFLAGS)|g' \
+ -e '/^CPPFLAGS/s|-D_BSD_SOURCE=1 -D_GNU_SOURCE=1|-D_DEFAULT_SOURCE=1|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}
diff --git a/app-text/an/an-1.2.ebuild b/app-text/an/an-1.2.ebuild
new file mode 100644
index 000000000000..ee3b460ecd60
--- /dev/null
+++ b/app-text/an/an-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/unstable/games/an"
+
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE=""
+
+CDEPEND="
+ dev-libs/icu:=
+"
+DEPEND="
+ app-arch/xz-utils
+"
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/miscfiles[-minimal]
+"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ -e 's|$(CC) $(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}
diff --git a/app-text/an/metadata.xml b/app-text/an/metadata.xml
new file mode 100644
index 000000000000..f5037f14a3cb
--- /dev/null
+++ b/app-text/an/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>