summaryrefslogtreecommitdiff
path: root/app-text/aha/aha-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aha/aha-0.5.1.ebuild')
-rw-r--r--app-text/aha/aha-0.5.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-text/aha/aha-0.5.1.ebuild b/app-text/aha/aha-0.5.1.ebuild
new file mode 100644
index 000000000000..2cb556e1e882
--- /dev/null
+++ b/app-text/aha/aha-0.5.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Converts ANSI escape sequences of a unix terminal to HTML code"
+HOMEPAGE="https://github.com/theZiz/aha"
+SRC_URI="https://github.com/theZiz/aha/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/${P}-null-ptr-dereference-fix.patch"
+)
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}