summaryrefslogtreecommitdiff
path: root/app-shells/zsh/zsh-5.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh/zsh-5.9.ebuild')
-rw-r--r--app-shells/zsh/zsh-5.9.ebuild23
1 files changed, 20 insertions, 3 deletions
diff --git a/app-shells/zsh/zsh-5.9.ebuild b/app-shells/zsh/zsh-5.9.ebuild
index a2940a5c435e..9cfcc3a75650 100644
--- a/app-shells/zsh/zsh-5.9.ebuild
+++ b/app-shells/zsh/zsh-5.9.ebuild
@@ -50,6 +50,13 @@ if [[ ${PV} == *9999 ]] ; then
)"
fi
+PATCHES=(
+ # add openrc specific options for init.d completion
+ "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
+ # Please refer gentoo bug 833981
+ "${FILESDIR}"/${PN}-5.9-musl-V09datetime-test-fix.patch
+)
+
src_prepare() {
if [[ ${PV} != *9999 ]]; then
# fix zshall problem with soelim
@@ -58,9 +65,6 @@ src_prepare() {
soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
fi
- # add openrc specific options for init.d completion
- eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
-
default
hprefixify configure.ac
@@ -132,6 +136,19 @@ src_compile() {
}
src_test() {
+ # Fixes tests A03quoting.ztst B03print.ztst on musl
+ # Please refer:
+ # https://www.zsh.org/mla/workers/2021/msg00805.html
+ # Test E02xtrace fails on musl, so we are removing it.
+ # Closes: https://bugs.gentoo.org/833981
+ if use elibc_musl ; then
+ unset LC_ALL
+ unset LC_COLLATE
+ unset LC_NUMERIC
+ unset LC_MESSAGES
+ unset LANG
+ rm "${S}"/Test/E02xtrace.ztst || die
+ fi
addpredict /dev/ptmx
local i
for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do