summaryrefslogtreecommitdiff
path: root/app-shells/loksh/loksh-6.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/loksh/loksh-6.8.1.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.8.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.8.1.ebuild b/app-shells/loksh/loksh-6.8.1.ebuild
new file mode 100644
index 000000000000..ca44f5e3fd4f
--- /dev/null
+++ b/app-shells/loksh/loksh-6.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/releases/download/${PV}/src.tar.xz -> ${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+
+RDEPEND="
+ ${DEPEND}
+ !app-shells/ksh
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ sed -i "/install_dir/s@loksh@${PF}@" meson.build || die
+}
+
+src_configure() {
+ # we want it as /bin/ksh
+ meson_src_configure --bindir=../bin
+}