summaryrefslogtreecommitdiff
path: root/app-shells/loksh/loksh-6.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/loksh/loksh-6.6.ebuild')
-rw-r--r--app-shells/loksh/loksh-6.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/loksh/loksh-6.6.ebuild b/app-shells/loksh/loksh-6.6.ebuild
new file mode 100644
index 000000000000..409607ab680a
--- /dev/null
+++ b/app-shells/loksh/loksh-6.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux port of OpenBSD's ksh"
+HOMEPAGE="https://github.com/dimkr/loksh"
+SRC_URI="https://github.com/dimkr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ !app-shells/ksh"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ BIN_DIR="${EROOT}/bin" \
+ DESTDIR="${D}" \
+ DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+
+ dodoc NOTES
+}