summaryrefslogtreecommitdiff
path: root/app-shells/liquidprompt
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/liquidprompt')
-rw-r--r--app-shells/liquidprompt/Manifest3
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.0.3.ebuild40
-rw-r--r--app-shells/liquidprompt/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
new file mode 100644
index 000000000000..b666a540698a
--- /dev/null
+++ b/app-shells/liquidprompt/Manifest
@@ -0,0 +1,3 @@
+DIST liquidprompt-2.0.3.tar.gz 539054 BLAKE2B c94375e0def1764103afe04bb47ff25ced2aeb940b45392bea8a2889ce88d1ea0e03efc0652ec8bc873b9910bee7208e48aaef9a846760177049cc550a5cd8b0 SHA512 a77f1548dd233de9877b2b5dd4a64f05ef03890917486792eb1c362708ab0b635c517cc2a3ddc82731940017f209f626d177a4ac0b5554566faa720a7d88b550
+EBUILD liquidprompt-2.0.3.ebuild 818 BLAKE2B 29cef421d5806b410ebe133d7985f4cd78ce1dadb1f5cd0ef2306968700dffd6d4270b4a41747287778d5b60bf3f5f14c32193b56e98fb9107a119a1b21e32f9 SHA512 9374d1a7ec9644cfc87e4123a165dc904d029b020b3bc037d165b26f75e04373166fb9719cb22b6b97a198a09ecc8445a2645673d1684eea5d2ef126a05d9160
+MISC metadata.xml 334 BLAKE2B 1ff1d288c66be8aabdce497995e8157432c260d4c96117f530aa49a809702ab5c6ba682100bd57f52e5434b1d507b9a4cf1308e96e6d791b68229da86dd98e36 SHA512 575e397183c1d08e3a69e32d8abd266eca2b49e9f70c87247f017b0113cb608acb0e9869aff06bc9f30f9e706a7ab535f6e6955523d053705fa3f1211b6cc6e3
diff --git a/app-shells/liquidprompt/liquidprompt-2.0.3.ebuild b/app-shells/liquidprompt/liquidprompt-2.0.3.ebuild
new file mode 100644
index 000000000000..037add1c934c
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins liquid.theme
+ doins liquid.ps1
+ doins -r themes
+
+ insinto /etc/
+ newins liquidpromptrc-dist liquidpromptrc
+}
diff --git a/app-shells/liquidprompt/metadata.xml b/app-shells/liquidprompt/metadata.xml
new file mode 100644
index 000000000000..6d5867c2f369
--- /dev/null
+++ b/app-shells/liquidprompt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nojhan/liquidprompt</remote-id>
+ </upstream>
+</pkgmetadata>