summaryrefslogtreecommitdiff
path: root/app-shells/hstr/hstr-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/hstr/hstr-2.2.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-2.2.ebuild b/app-shells/hstr/hstr-2.2.ebuild
new file mode 100644
index 000000000000..08f0c98ba78d
--- /dev/null
+++ b/app-shells/hstr/hstr-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=( ${FILESDIR}/${PN}-2.0-fix-ncurses-configure.patch )
+
+src_prepare() {
+ default
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+}